Bug 120908 - duplicate routes created
duplicate routes created
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: initscripts (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks: 116726 116727
  Show dependency treegraph
 
Reported: 2004-04-15 00:31 EDT by Dax Kelson
Modified: 2014-03-16 22:44 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-17 23:54:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Dax Kelson 2004-04-15 00:31:00 EDT
Description of problem:

I have a firewall box running RHEL3. It has 4 network interfaces and
two of which (eth2,eth3) are doing 802.1q VLANS. On the internet
facing interface (eth0) I have multiple IPs bound with virtual interfaces.

My routing table has the default route duplicated many times.

# netstat -rn
Kernel IP routing table
Destination     Gateway         Genmask         Flags   MSS Window 
irtt Iface
10.2.4.0        0.0.0.0         255.255.255.0   U         0 0        
 0 eth2.99
66.62.77.0      0.0.0.0         255.255.255.0   U         0 0        
 0 eth0
10.2.6.0        0.0.0.0         255.255.255.0   U         0 0        
 0 eth2.8
10.2.7.0        0.0.0.0         255.255.255.0   U         0 0        
 0 eth2.9
10.2.0.0        0.0.0.0         255.255.255.0   U         0 0        
 0 eth2.3
10.70.1.0       0.0.0.0         255.255.255.0   U         0 0        
 0 eth3.10
10.2.1.0        0.0.0.0         255.255.255.0   U         0 0        
 0 eth2.4
10.2.2.0        0.0.0.0         255.255.255.0   U         0 0        
 0 eth2.5
10.2.3.0        0.0.0.0         255.255.255.0   U         0 0        
 0 eth2.100
10.2.8.0        0.0.0.0         255.255.255.0   U         0 0        
 0 eth2.11
10.2.9.0        0.0.0.0         255.255.255.0   U         0 0        
 0 eth2.12
10.2.10.0       0.0.0.0         255.255.255.0   U         0 0        
 0 eth2.13
10.2.11.0       0.0.0.0         255.255.255.0   U         0 0        
 0 eth2.14
10.1.0.0        0.0.0.0         255.255.0.0     U         0 0        
 0 eth1
127.0.0.0       0.0.0.0         255.0.0.0       U         0 0        
 0 lo
0.0.0.0         66.62.77.1      0.0.0.0         UG        0 0        
 0 eth0
0.0.0.0         66.62.77.1      0.0.0.0         UG        0 0        
 0 eth0
0.0.0.0         66.62.77.1      0.0.0.0         UG        0 0        
 0 eth0
0.0.0.0         66.62.77.1      0.0.0.0         UG        0 0        
 0 eth0
0.0.0.0         66.62.77.1      0.0.0.0         UG        0 0        
 0 eth0
0.0.0.0         66.62.77.1      0.0.0.0         UG        0 0        
 0 eth0
0.0.0.0         66.62.77.1      0.0.0.0         UG        0 0        
 0 eth0
0.0.0.0         66.62.77.1      0.0.0.0         UG        0 0        
 0 eth0
0.0.0.0         66.62.77.1      0.0.0.0         UG        0 0        
 0 eth0
0.0.0.0         66.62.77.1      0.0.0.0         UG        0 0        
 0 eth0
0.0.0.0         66.62.77.1      0.0.0.0         UG        0 0        
 0 eth0
0.0.0.0         66.62.77.1      0.0.0.0         UG        0 0        
 0 eth0
0.0.0.0         66.62.77.1      0.0.0.0         UG        0 0        
 0 eth0

My GATEWAY is defined in my ifcfg-eth0 file and not
/etc/sysconfig/network.

I have the following ifcfg files:

ifcfg-eth0     ifcfg-eth0:2  ifcfg-eth0:7  ifcfg-eth2.100 
ifcfg-eth2.14  ifcfg-eth2.9
ifcfg-eth0:1   ifcfg-eth0:3  ifcfg-eth0:8  ifcfg-eth2.101 
ifcfg-eth2.3   ifcfg-eth2.99
ifcfg-eth0:10  ifcfg-eth0:4  ifcfg-eth0:9  ifcfg-eth2.11  
ifcfg-eth2.4   ifcfg-eth3
ifcfg-eth0:11  ifcfg-eth0:5  ifcfg-eth1    ifcfg-eth2.12  
ifcfg-eth2.5   ifcfg-eth3.10
ifcfg-eth0:12  ifcfg-eth0:6  ifcfg-eth2    ifcfg-eth2.13  
ifcfg-eth2.8   ifcfg-lo
Comment 1 Dax Kelson 2004-04-24 19:32:44 EDT
By moving the GATEWAY line *out* of ifcfg-eth0 and into
/etc/sysconfig/network the problem is fixed.

These duplicate default routes cause problems from certain software
like OpenSWAN.

Be aware that anaconda and redhat-config-network stick the GATEWAY
into the ifcfg files and not /etc/sysconfig/network.

So the problem of duplicate routes still needs fixing.
Comment 2 Bill Nottingham 2004-06-07 15:24:54 EDT
Is it only in ifcfg-eth0?
Comment 3 Bill Nottingham 2004-06-07 15:42:04 EDT
Ah, it's a 'function' of ifup-aliases.
Comment 4 Dax Kelson 2004-06-07 15:48:51 EDT
Yes, the GATEWAY line was only in ifcfg-eth0.
Comment 5 Bill Nottingham 2004-06-07 15:56:50 EDT
As for the fix, search for 'broken' in ifup-aliases, and remove that
block. :)
Comment 6 Bill Nottingham 2004-06-24 16:50:28 EDT
Fixed in 7.31.14.EL-1/6.47.9-1.
Comment 7 Jay Turner 2004-08-17 23:54:05 EDT
Fix confirmed with initscripts-7.31.16.EL-1.
Comment 8 Jay Turner 2004-09-01 23:26:22 EDT
An errata has been issued which should help the problem 
described in this bug report. This report is therefore being 
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, 
please follow the link below. You may reopen this bug report 
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2004-328.html

Note You need to log in before you can comment on or make changes to this bug.