Bug 120910 - ppp dies after dial up, return value 4
ppp dies after dial up, return value 4
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: ppp (Show other bugs)
9
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Thomas Woerner
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-15 01:23 EDT by Elmer E. Dow
Modified: 2007-04-18 13:06 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-21 10:52:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Elmer E. Dow 2004-04-15 01:23:54 EDT
Description of problem: I have an IBM R40 laptop set up as dual boot 
to WinXP or Linux. In Linux, ppp dies whenever I attempt to connect 
to my ISP.

I first tried a SmartLink modem driver, which dialed in and 
connected, but then weird things would happen -- freeze ups, 
extremely slow processing, etc.

I then found a download link for a driver from Agere Systems at the 
IBM site, so I uninstalled the SmartLink driver, compiled the Agere 
driver and installed it. It dials and logs in with the ISP, but then 
the ppp daemon dies. I've tried using wvdial, minicom and kppp, but 
results are the same. 

If I type "ppp" at the terminal, it generates garbage, so I'm 
assuming that ppp is really there, it just won't start when I make a 
connection.

If I do the above, then attempt a dial-in connection to my ISP, it 
connects, but applications such as Mozilla won't work.

I tried reinstalling the ppp rpm, but still no success. Shutting down 
the ethernet (which I don't use) with "ifconfig eth0 down" doesn't 
help. Sound is flaky: Sometimes I can hear the modem dialing but 
usually not. My dial-in attempts are done as root in order to 
eliminate possibilities of permission problems.

I've run scanModem and posted on the Linmodems.org discussion list. 
The conclusions drawn there was that I'm not having a modem driver 
problem. They think that it's a ppp problem and have suggested that I 
upgrade to a newer kernel.

I've wasted six months on this and would really appreciate any help I 
could get so that I can get away from WinXP completely.



Version-Release number of selected component (if applicable):kernel 
2.4.20-20.9


Reproducibility: Every time


Steps to Reproduce:
1.Attempt to dial in to ISP
2.
3.
  
Actual results: ppp dies


Expected results: ppp should start


Additional info:
Comment 1 Elmer E. Dow 2004-04-15 01:30:26 EDT
I get the following message:

Opener: received OpenDevice
Opener: received ExecPPPDaemon
In parent: pppd pid 3553
Kernel supports ppp alright.
Couldn't find interface ppp0: No such device
pppd: This system lacks kernel support for PPP.  This could be because
the PPP kernel module could not be loaded, or because PPP was not
included in the kernel configuration.  If PPP was included as a
module, try `/sbin/modprobe -v ppp'.  If that fails, check that
ppp.o exists in /lib/modules/`uname -r`/net.
See README.linux file in the ppp distribution for more details.

It was pppd that died
pppd exited with return value 4
Sending 3536 a SIGUSR1

Often I get many lines saying "Couldn't find interface ppp0: No such
device."
Comment 2 Thomas Woerner 2004-04-21 10:52:39 EDT
I am sorry, but I have two problems:

- This is a binary driver. I can not look into the source code.
- I have no IBM R40, therefore I can not reproduce it.

Closing wontfix.

Note You need to log in before you can comment on or make changes to this bug.