Bug 1209169 - Konqueror by default opens as a file manager
Summary: Konqueror by default opens as a file manager
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: plasma-desktop
Version: 22
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: KDE SIG
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F22Blocker-kde
TreeView+ depends on / blocked
 
Reported: 2015-04-06 14:40 UTC by Branko Grubić
Modified: 2015-04-30 11:43 UTC (History)
11 users (show)

Fixed In Version: plasma-desktop-5.2.2-5.fc22
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-04-30 11:43:09 UTC
Type: Bug


Attachments (Terms of Use)

Description Branko Grubić 2015-04-06 14:40:16 UTC
Description of problem:
In f22 Beta tc8, konqueror from Favorites (kicker?) by default opens as a file manager.

If I create a shortcut on the desktop (drag&drop -> (kfmclient_html.desktop))(Folder layout, not Desktop with widgets (default)), it is hidden, and command is 'kfmclient openURL %u text/html'

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Rex Dieter 2015-04-22 20:25:22 UTC
reassigning to plasma-desktop, this is currently implemented via
plasma-desktop-5.2.1-default_favorites.patch

Comment 2 Rex Dieter 2015-04-22 20:27:26 UTC
Hrm,

http://pkgs.fedoraproject.org/cgit/plasma-desktop.git/tree/plasma-desktop-5.2.1-default_favorites.patch

Currently this only difference to default is the addition of konsole and apper,

-        applications << browser << "kontact" << "systemsettings" << "dolphin" << "ktp-contactlist" << "kate";
+        applications << browser << "kontact" << "systemsettings" << "dolphin" << "ktp-contactlist" << "kate" << "org.kde.konsole" << "apper";

Comment 3 Rex Dieter 2015-04-22 20:40:28 UTC
Besides the aforementioned
applets/kickoff/core/favoritesmodel.cpp

which we patch, there's also:
applets/kicker/package/contents/config/main.xml
which contains:

<entry name="favoriteApps" type="StringList">      <default>preferred://browser,kontact.desktop,systemsettings.desktop,org.kde.dolphin.desktop,ktp-contactlist.desktop,org.kde.kate.desktop</default>
</entry>

Comment 4 Rex Dieter 2015-04-22 21:04:47 UTC
OK, I think I'm convinced this is not a fedora/downstream issue.

In short, the default out-of-the-box configuration for "default browser" ends up being:
/usr/share/applications/kde4/kfmclient_html.desktop
with
Exec=kfmclient openURL %u text/html

Since kfmclient_html.desktop ends up with highest preference for handling text/html mimetype (as it should).  But, if opened with empty URL, it ends up exhibiting this bug.


It may be possible to hard-code "Default Browser" to be konqueror to workaround this, ie, set in kdeglobals:
[General]
BrowserApplication[$e]=!konqueror
So that ends up being displayed @ systemsettings5->Applications->Default Applications->Web Browser, instead of the default:
"in an application based on the contents of the URL"

though I'm worried about the possible side-effects of making *that* change. :-/

Comment 5 Fedora Update System 2015-04-23 13:49:26 UTC
plasma-desktop-5.2.2-5.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/plasma-desktop-5.2.2-5.fc22

Comment 6 Rex Dieter 2015-04-23 18:53:49 UTC
the immediate fix I went for here, fwiw, was to hard-code konqueror as the favorite, instead of relying on plasma-desktop code to deduce "default browser", which as shown here, has some problems.

Comment 7 Fedora Update System 2015-04-24 22:47:26 UTC
Package plasma-desktop-5.2.2-5.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing plasma-desktop-5.2.2-5.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-6769/plasma-desktop-5.2.2-5.fc22
then log in and leave karma (feedback).

Comment 8 Fedora Update System 2015-04-30 11:43:09 UTC
plasma-desktop-5.2.2-5.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.