Bug 1209185 - In RHEV Manager, viewing Templates then virtual machines doesn't show virtual machine name field
Summary: In RHEV Manager, viewing Templates then virtual machines doesn't show virtual...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 3.5.0
Hardware: All
OS: Linux
unspecified
high
Target Milestone: ovirt-3.6.0-rc
: 3.6.0
Assignee: Tomas Jelinek
QA Contact: Nisim Simsolo
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-04-06 15:47 UTC by Allie DeVolder
Modified: 2019-09-12 08:24 UTC (History)
12 users (show)

Fixed In Version: 3.6.0-5
Doc Type: Bug Fix
Doc Text:
Previously, the names of virtual machines based on a given template would not be shown in the Virtual Machines subtab of the Templates tab under certain conditions. Now, the names of virtual machines based on the selected template are displayed correctly.
Clone Of:
Environment:
Last Closed: 2016-03-09 21:01:55 UTC
oVirt Team: Virt


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:0376 normal SHIPPED_LIVE Red Hat Enterprise Virtualization Manager 3.6.0 2016-03-10 01:20:52 UTC
oVirt gerrit 44230 master MERGED webadmin: template main tab -> vm subtab -> vm name may disappear Never

Description Allie DeVolder 2015-04-06 15:47:29 UTC
Description of problem:
In RHEV Manager, viewing Templates then virtual machines doesn't show virtual machine name field

Version-Release number of selected component (if applicable):
3.5

How reproducible:
Unknown

Steps to Reproduce:
1. Start a "fresh" browser
2. Select "Virtual Machines" tab. 
3. Click on the "Templates" tab, select a template that has VMs attached to it)
4. Click the "Virtual Machines" sub-tab under templates. 

Actual results:
 The Name of the virtual machine does NOT show. If I then CLOSE the SYSTEM pane, resize the Name column of the virtual machines under templates, reopen the SYSTEM pane, the Name appears.

Expected results:
NAME column rendered properly

Additional info:

Comment 1 Tomas Jelinek 2015-07-08 08:57:27 UTC
I can not simulate this on 3.5.3.1-1.4.el6ev nor on current master branch. Tried firefox and chrome, so I have some more questions:

1: is this still happening?

if yes, than

2: what browser? (including version)
3: what exact version of ovirt
4: any frontend exceptions? (e.g. in the javascript console of the browser any stack trace?)

Comment 3 Tomas Jelinek 2015-07-31 08:56:07 UTC
OK, finally simulated - it happens on smaller screens only. Since the name did not have the minimal width set it have appeared and disappeared based on the situation around.

Fixed by setting it a width since it is important to make the name field always shown.

Comment 4 Nisim Simsolo 2015-09-22 09:32:46 UTC
Fixed. 
Verified: rhevm-3.6.0-0.13.master.el6

Comment 7 errata-xmlrpc 2016-03-09 21:01:55 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0376.html


Note You need to log in before you can comment on or make changes to this bug.