Bug 1209243 - wondershaper depends on kernel-modules-extra
Summary: wondershaper depends on kernel-modules-extra
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: wondershaper
Version: 21
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Mosaab Alzoubi
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-04-06 19:31 UTC by Francisco de la Peña
Modified: 2015-08-23 16:41 UTC (History)
4 users (show)

Fixed In Version: 1.2.1-5.fc23
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-08-19 08:10:36 UTC


Attachments (Terms of Use)

Description Francisco de la Peña 2015-04-06 19:31:38 UTC
Description of problem:

wondershaper depends on some QoS related modules not installed by default and not dependent when installing the package.

Version-Release number of selected component (if applicable):
1.2.1-3.fc21

How reproducible:
Always when kernel-modules-extra is not installed.

Steps to Reproduce:
# wondershaper interfacename 1234 5678

Actual results:
Multiple "RTNETLINK answers: No such file or directory"
and "We have an error talking to the kernel" messages returned.
Won't work after running the command.

Expected results:
Work and don't show these messages.

Additional info:
Remember kernel-modules-extra are not modprobed by default after installing without rebooting first.

Comment 1 Fedora Update System 2015-08-08 10:20:40 UTC
wondershaper-1.2.1-5.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/wondershaper-1.2.1-5.fc21

Comment 2 Fedora Update System 2015-08-08 10:21:06 UTC
wondershaper-1.2.1-5.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/wondershaper-1.2.1-5.fc22

Comment 3 Fedora Update System 2015-08-08 10:21:32 UTC
wondershaper-1.2.1-5.el7 has been submitted as an update for Fedora EPEL 7.
https://admin.fedoraproject.org/updates/wondershaper-1.2.1-5.el7

Comment 4 Fedora Update System 2015-08-08 10:21:51 UTC
wondershaper-1.2.1-5.fc23 has been submitted as an update for Fedora 23.
https://admin.fedoraproject.org/updates/wondershaper-1.2.1-5.fc23

Comment 5 Fedora Update System 2015-08-08 20:03:45 UTC
Package wondershaper-1.2.1-5.el7:
* should fix your issue,
* was pushed to the Fedora EPEL 7 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing wondershaper-1.2.1-5.el7'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2015-7559/wondershaper-1.2.1-5.el7
then log in and leave karma (feedback).

Comment 6 lnie 2015-08-10 06:03:55 UTC
wondershaper-1.2.1-5.fc22 works

Comment 7 Anssi Johansson 2015-08-10 06:51:03 UTC
wondershaper-1.2.1-5.el7 does not. There is no kernel-modules-extra package available in EL7, as far as I can see. Please revert the change for EPEL7.

Comment 8 Mosaab Alzoubi 2015-08-10 09:51:45 UTC
Reverted for epel7

Comment 9 Fedora Update System 2015-08-11 02:13:40 UTC
wondershaper-1.2.1-5.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2015-08-19 08:10:36 UTC
wondershaper-1.2.1-5.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2015-08-23 16:41:22 UTC
wondershaper-1.2.1-5.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.