Bug 1209270 - Can't Join IPA Domain from Cockpit
Summary: Can't Join IPA Domain from Cockpit
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: freeipa
Version: 22
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: IPA Maintainers
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F22BetaBlocker
TreeView+ depends on / blocked
 
Reported: 2015-04-06 22:12 UTC by Dan Mossor [danofsatx]
Modified: 2015-04-07 23:11 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-04-07 23:11:35 UTC


Attachments (Terms of Use)

Description Dan Mossor [danofsatx] 2015-04-06 22:12:50 UTC
Fedora Server Beta Release Criteria[0] test of joining an IPA domain from Cockpit fails with this output:

* Resolving: _ldap._tcp.example.lcl

 * Performing LDAP DSE lookup on: 10.1.0.1

 * Successfully discovered: example.lcl

 * Required files: /usr/sbin/ipa-client-install, /usr/sbin/oddjobd, /usr/libexec/oddjob/mkhomedir, /usr/sbin/sssd

 * LANG=C /usr/sbin/ipa-client-install --domain example.lcl --realm EXAMPLE.LCL --mkhomedir --enable-dns-updates --unattended --force-join --principal admin -W --force-ntpd

There was a problem importing one of the required Python modules. The
error was:

    No module named SSSDConfig


 ! Running ipa-client-install failed

Proposing as a blocker based on criteria listed.

[0]https://fedoraproject.org/wiki/QA:Testcase_realmd_join_cockpit

Comment 1 Fedora Blocker Bugs Application 2015-04-06 22:16:01 UTC
Proposed as a Blocker for 22-beta by Fedora user dmossor using the blocker tracking app because:

 Proposing as a blocker as it violates the Beta Release Criteria "Testcase realmd join cockpit".

https://fedoraproject.org/wiki/QA:Testcase_realmd_join_cockpit

Comment 2 Dan Mossor [danofsatx] 2015-04-06 22:26:24 UTC
Also fails from command line -same error. Reassigning to freeipa, as it is ipa-client-install that is failing, not cockpit.

[root@server-btc8 ~]# realm join --user=admin vader.example.lcl
Password for admin: 
See: journalctl REALMD_OPERATION=r1435.2329
realm: Couldn't join realm: Running ipa-client-install failed
[root@server-btc8 ~]# journalctl REALMD_OPERATION=r1435.2329
-- Logs begin at Mon 2015-04-06 16:54:04 CDT, end at Mon 2015-04-06 17:18:04 CDT. --
Apr 06 17:17:59 server-btc8.example.lcl realmd[2237]:  * Resolving: _ldap._tcp.vader.example.lcl
Apr 06 17:17:59 server-btc8.example.lcl realmd[2237]:  * Resolving: vader.example.lcl
Apr 06 17:17:59 server-btc8.example.lcl realmd[2237]:  * Performing LDAP DSE lookup on: 10.1.0.1
Apr 06 17:17:59 server-btc8.example.lcl realmd[2237]:  * Successfully discovered: example.lcl
Apr 06 17:18:04 server-btc8.example.lcl realmd[2237]:  * Required files: /usr/sbin/ipa-client-install, /usr/sbin/oddjobd, /usr/libexec/oddjob/mkhomedir, /usr/sbin/sssd
Apr 06 17:18:04 server-btc8.example.lcl realmd[2237]:  * LANG=C /usr/sbin/ipa-client-install --domain example.lcl --realm EXAMPLE.LCL --mkhomedir --enable-dns-updates --unattended --force-join --server vader.example.lcl -
Apr 06 17:18:04 server-btc8.example.lcl realmd[2237]: There was a problem importing one of the required Python modules. The
Apr 06 17:18:04 server-btc8.example.lcl realmd[2237]: error was:
Apr 06 17:18:04 server-btc8.example.lcl realmd[2237]: 
Apr 06 17:18:04 server-btc8.example.lcl realmd[2237]:     No module named SSSDConfig
Apr 06 17:18:04 server-btc8.example.lcl realmd[2237]: 
Apr 06 17:18:04 server-btc8.example.lcl realmd[2237]:  ! Running ipa-client-install failed

Comment 3 Adam Williamson 2015-04-06 23:48:48 UTC
Does it work if you install python-sssdconfig and/or python3-sssdconfig ?

Comment 4 Petr Vobornik 2015-04-07 07:42:43 UTC
what is the version of freeipa-client package? python-sssdconfig dependency was added in freeipa-client-0:4.1.3-2.fc22

$ rpm -qf /usr/lib/python2.7/site-packages/SSSDConfig
python-sssdconfig-1.12.4-2.fc22.noarch

$ repoquery --whatrequires python-sssdconfig
authconfig-0:6.2.10-3.fc22.x86_64
authconfig-0:6.2.10-6.fc22.x86_64
freeipa-client-0:4.1.4-1.fc22.x86_64
freeipa-server-0:4.1.4-1.fc22.x86_64

Comment 5 Stephen Gallagher 2015-04-07 16:46:50 UTC
Dan, I just installed Fedora Server 22 Beta TC8 in a VM, connected with Cockpit and joined a FreeIPA domain successfully. I can't reproduce this issue.

Voting -1 blocker.

Comment 6 Dan Mossor [danofsatx] 2015-04-07 17:42:06 UTC
freeipa-client-4.1.4-1.fc22.x86_64

Odd, SSSDConfig is actually in /usr/lib/python2.7/site-packages/ but python didn't find it for some reason.

Comment 7 Adam Williamson 2015-04-07 17:46:03 UTC
note python-sssdconfig vs. python3-sssdconfig ; is this stuff running as python 3?

Comment 8 Stephen Gallagher 2015-04-07 18:37:50 UTC
(In reply to awilliam@redhat.com from comment #7)
> note python-sssdconfig vs. python3-sssdconfig ; is this stuff running as
> python 3?

freeipa-client is still using Python 2 and has an explicit Requires: python-sssdconfig, so if freeipa-client-install is on the system, so too must be python-sssdconfig.

I have no explanation for this (and I cannot reproduce it).

Comment 9 Dan Mossor [danofsatx] 2015-04-07 23:11:35 UTC
Error on my part. I misread the link and ISO name, and was erroneously testing Alpha TC8.


Note You need to log in before you can comment on or make changes to this bug.