This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 120929 - unnecessary and annoying dependence on mozilla
unnecessary and annoying dependence on mozilla
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
1
All Linux
medium Severity low
: ---
: ---
Assigned To: Dan Williams
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-15 08:05 EDT by Anand Buddhdev
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-03 04:27:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Anand Buddhdev 2004-04-15 08:05:49 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040404 Firefox/0.8

Description of problem:
This latest update of openoffice requires mozilla. Not all of us use
mozilla. I personally use firefox. I removed mozilla from my system,
because I didn't want programs randomly starting up mozilla (many
programs are configured to simply run "mozilla" when a browser is
required). On my system I have a shell script called "mozilla" that
starts firefox (optionally opening my page in a tab if firefox is
already running). I don't want to install mozilla, and this update of
openoffice is forcing me to get it. I could manually download the
updates and install using "rpm --nodeps", but I will face this problem
the next time I try to update or upgrade. Since firefox is now a part
of the fedora distribution, is it not better to have a dependency on
mozilla OR firefox, so that people like me are not forced to have a
copy of mozilla on our system?

Version-Release number of selected component (if applicable):
openoffice.org-1.1.0-15

How reproducible:
Always

Steps to Reproduce:
1. Attempt to update or install openoffice.org using yum or any other tool
2.
3.
    

Additional info:
Comment 1 Dan Williams 2004-04-15 11:13:46 EDT
OOo has always required Mozilla to build at least, and technically
requires Mozilla to use the address book integration...  This is not
the case with FC2 however where this has been stripped out due to
other concerns.  I suppose the requirement could be removed...
Comment 2 Anand Buddhdev 2004-04-15 12:33:32 EDT
Ok, that's good news. So are you going to remove the dependency now
and release a new update of OOo, or will I have to wait until the next
proper version/bugfix update?
Comment 3 Caolan McNamara 2004-11-03 04:27:15 EST
openoffice.org-1.1.0-15 in FC1 updates and the later FC2/FC3
openoffice.org-1.1.2-10 no longer have a Requires on mozilla
Comment 4 Caolan McNamara 2004-11-03 04:27:34 EST
openoffice.org-1.1.0-16 in FC1 updates and the later FC2/FC3
openoffice.org-1.1.2-10 no longer have a Requires on mozilla

Note You need to log in before you can comment on or make changes to this bug.