Bug 12093 - XF86_S3 crash with Diamond Stealth 64
Summary: XF86_S3 crash with Diamond Stealth 64
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
high
Target Milestone: ---
Assignee: Preston Brown
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-06-11 18:36 UTC by Tim Waugh
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-06-12 11:32:28 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
XF86_S3 -xf86config /tmp/XF86Config.test (3.43 KB, text/plain)
2000-06-11 18:40 UTC, Tim Waugh
no flags Details
echo where | gdb XF86_S3 core (1.08 KB, text/plain)
2000-06-11 18:41 UTC, Tim Waugh
no flags Details

Description Tim Waugh 2000-06-11 18:40:01 UTC
(My report got eaten by bugzilla.  I'll try attaching files instead.)

Got an X crash.  Managed to reproduce it on VT2 with VT1 on scroll-lock to
prevent rebooting.  Used ulimit -c unlimited to get a core.  Used ftp to
analyse it.

I've mailed XFree86@XFree86.org already.

Comment 1 Tim Waugh 2000-06-11 18:40:56 UTC
Created attachment 400 [details]
XF86_S3 -xf86config /tmp/XF86Config.test

Comment 2 Tim Waugh 2000-06-11 18:41:34 UTC
Created attachment 401 [details]
echo where | gdb XF86_S3 core

Comment 3 Tim Waugh 2000-06-12 11:32:26 UTC
Incidentally, this is on a 486 that's it's happening.  I guess that's probably
relevant since the crash is from a SIGILL.  Is the XF86_S3 binary built i386?


Comment 4 Tim Waugh 2000-06-15 10:07:21 UTC
I've investigated this a bit further.

The XF86_S3 that's actually _installed_ works fine with the XF86Config.test from
the installer, but the one on the CD that I burnt doesn't.  I think it must just
be a bad CD (the XF86_S3 grabbed from the CD is different than the one in the
iso image).

Sorry for the bogus report.



Note You need to log in before you can comment on or make changes to this bug.