Bug 1209312 - virsh domifaddr cannot get any output in quiet mode
Summary: virsh domifaddr cannot get any output in quiet mode
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libvirt
Version: 7.2
Hardware: x86_64
OS: Linux
low
low
Target Milestone: rc
: ---
Assignee: Libvirt Maintainers
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-04-07 03:02 UTC by Luyao Huang
Modified: 2015-11-19 06:27 UTC (History)
5 users (show)

Fixed In Version: libvirt-1.2.15-1.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-11-19 06:27:17 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:2202 0 normal SHIPPED_LIVE libvirt bug fix and enhancement update 2015-11-19 08:17:58 UTC

Description Luyao Huang 2015-04-07 03:02:35 UTC
description of problem:
virsh domifaddr cannot get any output in quiet mode

Version-Release number of selected component (if applicable):
libvirt-1.2.14-1.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1.prepare a running vm with agent:
# virsh list
 Id    Name                           State
----------------------------------------------------
 6     test3                          running

2.check output
# virsh domifaddr test3 --source agent
 Name       MAC address          Protocol     Address
-------------------------------------------------------------------------------
 lo         00:00:00:00:00:00    ipv4         127.0.0.1/8
 -          -                    ipv6         ::1/128
 ens8       52:54:00:1a:cb:3f    ipv6         fe80::5054:ff:fe1a:cb3f/64
 virbr0     52:54:00b:51:e7    ipv4         192.168.122.1/24
 virbr0-nic 52:54:00b:51:e7    N/A          N/A

3. heck quite model output
# virsh -q domifaddr test3 --source agent

Actual results:
virsh domifaddr cannot get any output in quiet mode

Expected results:
fix it

# virsh -q domifaddr test3 --source agent
 lo         00:00:00:00:00:00    ipv4         127.0.0.1/8
 -          -                    ipv6         ::1/128
 ens8       52:54:00:1a:cb:3f    ipv6         fe80::5054:ff:fe1a:cb3f/64
 virbr0     52:54:00b:51:e7    ipv4         192.168.122.1/24
 virbr0-nic 52:54:00b:51:e7    N/A          N/A

Additional info:

Upstream patch:

commit 156fde0b1a7d9421403401b837152990a900c88b
Author: Luyao Huang <lhuang@redhat.com>
Date:   Fri Apr 3 17:41:03 2015 +0800

    virsh: Fix domifaddr output in quiet mode
    
    In virsh we have two printing functions: vshPrint() which prints a
    string onto stdout and vshPrintExtra() which does not print anything
    if virsh is run in quiet mode. Usually, the former is used to print
    actual results, while the latter to print strings like table headers
    and other formatting stuff. However, in cmdDomIfAddr we have
    mistakenly used vshPrintExtra even for actual data. After this patch,
    the output should look like the following:
    
      # virsh -q domifaddr test3 --source agent
      lo         00:00:00:00:00:00    ipv4         127.0.0.1/8
      -          -                    ipv6         ::1/128
      ens8       52:54:00:1a:cb:3f    ipv6         fe80::5054:ff:fe1a:cb3f/64
      virbr0     52:54:00:db:51:e7    ipv4         192.168.122.1/24
      virbr0-nic 52:54:00:db:51:e7    N/A          N/A

v1.2.14-44-g156fde0

Comment 2 Fangge Jin 2015-07-01 10:57:12 UTC
I can reproduce this bug on build:
libvirt-1.2.14-1.el7.x86_64

Verify this bug on build:
libvirt-1.2.16-1.el7.x86_64

Verify steps:
1.Prepare a running guest(r71) with agent:
# virsh list
 Id    Name                           State
----------------------------------------------------
 6     r71                            running

2.Add a new network hardware(eth1) for r71, but don't assign ip address.

3.
# virsh domifaddr r71 --source agent
 Name       MAC address          Protocol     Address
-------------------------------------------------------------------------------
 lo         00:00:00:00:00:00    ipv4         127.0.0.1/8
 -          -                    ipv6         ::1/128
 eth0       52:54:00:7f:d6:5e    ipv4         192.168.122.203/24
 -          -                    ipv6         fe80::5054:ff:fe7f:d65e/64
 eth1       52:54:00:3b:a6:e4    N/A          N/A

4.
# virsh -q domifaddr r71 --source agent
 lo         00:00:00:00:00:00    ipv4         127.0.0.1/8
 -          -                    ipv6         ::1/128
 eth0       52:54:00:7f:d6:5e    ipv4         192.168.122.203/24
 -          -                    ipv6         fe80::5054:ff:fe7f:d65e/64
 eth1       52:54:00:3b:a6:e4    N/A          N/A

5.
# virsh -q domifaddr r71 --source lease
 vnet0      52:54:00:7f:d6:5e    ipv4         192.168.122.203/24

6.
# virsh -q domifaddr r71 
 vnet0      52:54:00:7f:d6:5e    ipv4         192.168.122.203/24


The bug has been fixed, so move to verified.

Comment 4 errata-xmlrpc 2015-11-19 06:27:17 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2202.html


Note You need to log in before you can comment on or make changes to this bug.