Bug 1209356 - virt-who's new configure file /etc/virt-who.d/XXX can't be save after reboot rhevh
Summary: virt-who's new configure file /etc/virt-who.d/XXX can't be save after reboot ...
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node
Version: 3.5.0
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ovirt-3.6.2
: 3.6.2
Assignee: Ryan Barry
QA Contact: Huijuan Zhao
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-04-07 07:18 UTC by Liushihui
Modified: 2016-03-09 14:22 UTC (History)
13 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2016-03-09 14:22:22 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:0378 normal SHIPPED_LIVE ovirt-node bug fix and enhancement update for RHEV 3.6 2016-03-09 19:06:36 UTC
oVirt gerrit 39730 master MERGED Add on-shutdown hooks Never
oVirt gerrit 49029 ovirt-3.6 MERGED Add on-shutdown hooks Never
oVirt gerrit 50344 master MERGED Remove hooks/on-shutdown/01-save-virtwho, add persistence to inst 2015-12-22 13:25 UTC
oVirt gerrit 50918 ovirt-3.6 MERGED Remove hooks/on-shutdown/01-save-virtwho, add persistence to inst 2015-12-22 15:01 UTC

Description Liushihui 2015-04-07 07:18:14 UTC
Description of problem:
As virt-who support another configure file which located in the catalog of /etc/virt-who.d/, this configure file should be saved after reboot rhevh.

Version-Release number of selected component (if applicable):
rhevh-vdsm7-7.1-20150402.0.el7ev
virt-who-0.11-5.el7.noarch

How reproducible:
Always

Steps to Reproduce:
1.Configure virt-who(/etc/virt-who.d/virtwho) run at rhevm mode.
# cat /etc/virt-who.d/virtwho
[test-rhevm1]
type=rhevm
server=https://10.66.79.58:443
username=admin@internal
password=redhat
owner=ACME_Corporation
env=Library
2.Reboot rhevh system, check this file /etc/virt-who.d/virtwho

Actual results:
/etc/virt-who.d/virtwho isn't exist after reboot rhevh

Expected results:
/etc/virt-who.d/virtwho should also be saved after reboot rhevh

Additional info:
the configure name "virtwho" is not specified, it's by define.

Comment 1 Ryan Barry 2015-04-08 14:43:05 UTC
Just to confirm:

You're manually creating /etc/virt-who.d/virtwho?

We can add something which persists all the files in /etc/virt-who.d/ on shutdown/reboot, but I'd like to know the possible files to save. Can it be anything in /etc/virt-who.d/?

Comment 2 Liushihui 2015-04-09 06:16:30 UTC
Yes, Any file in /etc/virt-who.d/ should be persist. Thanks.

(In reply to Ryan Barry from comment #1)
> Just to confirm:
> 
> You're manually creating /etc/virt-who.d/virtwho?
> 
> We can add something which persists all the files in /etc/virt-who.d/ on
> shutdown/reboot, but I'd like to know the possible files to save. Can it be
> anything in /etc/virt-who.d/?

Comment 3 Liushihui 2015-04-09 06:17:25 UTC
rhevh-vdsm6-6.6-20150402.0 also has the same problem

Comment 4 Liushihui 2015-07-10 09:06:28 UTC
It also exist on Rhev-hypervisor-6-6.7-20150707.0

Comment 5 Sandro Bonazzola 2015-10-26 12:50:18 UTC
this is an automated message. oVirt 3.6.0 RC3 has been released and GA is targeted to next week, Nov 4th 2015.
Please review this bug and if not a blocker, please postpone to a later release.
All bugs not postponed on GA release will be automatically re-targeted to

- 3.6.1 if severity >= high
- 4.0 if severity < high

Comment 6 Radek Novacek 2015-11-24 11:30:25 UTC
Btw: next version of virt-who will introduce new file /etc/virt-who.conf. Is it necessary for ovirt-node to make this file editable? Should I create new bug for that?

Comment 7 Fabian Deutsch 2015-11-24 12:06:52 UTC
Radek, thanks for the heads up.
Yes, we need to persist the file.

Could you consider to keep that file  in the /etc/virt-who.d folder?

Comment 8 Radek Novacek 2015-11-24 12:29:38 UTC
I don't think it's a good idea to keep that in /etc/virt-who.d folder, because:

* Our users might already have virt-who.conf file in the /etc/virt-who.d directory. I think that if someone needs to create only one config file for virt-who, it is quite probable that he names it virt-who.conf.

* compatibility with other programs. It's quite common to have main config file named {program}.conf and then a directory {program}.d for additional config files. Looking to the /etc on my system, following programs are using this schema: ant, dnsmasq, logrotate, rsyslog, sysctl, etc.

For these reasons I would like to call this file /etc/virt-who.conf.

Comment 9 Fabian Deutsch 2015-11-24 13:24:43 UTC
Yes, yes, I agree with both reasons above - I'd argue that way myself.

Comment 10 Radek Novacek 2015-11-24 13:29:37 UTC
So should I create a new bug for that?

Comment 11 Fabian Deutsch 2015-11-24 13:36:34 UTC
Yes please. Can you also tell when that virt-who version will land?

Comment 12 Radek Novacek 2015-11-24 13:47:16 UTC
Bug created: https://bugzilla.redhat.com/show_bug.cgi?id=1284934

Comment 14 Huijuan Zhao 2015-12-11 08:56:16 UTC
Still encounter this issue (same as comment 0) in rhev-hypervisor-7-7.2-20151210.1.e17ev.

Test version:
rhev-hypervisor-7-7.2-20151210.1.e17ev
ovirt-node-3.6.0-0.24.20151209gitc0fa931.el7ev.noarch

Test Steps:
1.Configure virt-who(/etc/virt-who.d/virtwho) run at rhevm mode.
# cat /etc/virt-who.d/virtwho
[test-rhevm1]
type=rhevm
server=https://10.66.79.58:443
username=admin@internal
password=redhat
owner=ACME_Corporation
env=Library
2.Reboot rhevh system, check this file /etc/virt-who.d/virtwho

Actual results:
/etc/virt-who.d/virtwho isn't exist after reboot rhevh

Additional:
There is no /etc/virt-who.conf file

So this bug is not fix in rhev-hypervisor-7-7.2-20151210.1.e17ev, change the status to ASSIGNED

Comment 15 Huijuan Zhao 2016-01-04 05:23:50 UTC
Test version:
rhev-hypervisor-7-7.2-20151229.0.e17ev
ovirt-node-3.6.1-1.0.el7ev.noarch

Test Steps:
1.Configure virt-who(/etc/virt-who.d/virtwho) run at rhevm mode.
# cat /etc/virt-who.d/virtwho
[test-rhevm1]
type=rhevm
server=https://10.66.79.58:443
username=admin@internal
password=redhat
owner=ACME_Corporation
env=Library
2.Reboot rhevh system, check this file /etc/virt-who.d/virtwho

Test results:
/etc/virt-who.d/virtwho is exist after reboot rhevh


So this bug is fix in rhev-hypervisor-7-7.2-20151229.0.e17ev, change the status to VERIFIED

Comment 17 errata-xmlrpc 2016-03-09 14:22:22 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0378.html


Note You need to log in before you can comment on or make changes to this bug.