Bug 1209381 - When named search is opened for edit, it does not expand sections that have content
Summary: When named search is opened for edit, it does not expand sections that have c...
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Bugzilla
Classification: Community
Component: User Interface
Version: 4.4
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: 5.0
Assignee: Jeff Fearn 🐞
QA Contact: Jeff Fearn 🐞
URL:
Whiteboard:
Depends On:
Blocks: UI-Modernization
TreeView+ depends on / blocked
 
Reported: 2015-04-07 08:49 UTC by Jan Pazdziora
Modified: 2018-12-09 06:29 UTC (History)
2 users (show)

Fixed In Version: 5.0.4-rh2
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-18 10:15:05 UTC


Attachments (Terms of Use)

Description Jan Pazdziora 2015-04-07 08:49:52 UTC
Description of problem:

I have named search which has some rules in the Custom Search section. However, when I click Edit Search and https://bugzilla.redhat.com/query.cgi?... is opened, the section "Custom Search" is collapsed and you have to click it to view the definition of my saved query.

It'd be good if the sections that contain some content got expanded by default.

Version-Release number of selected component (if applicable):

bugzilla.redhat.com as of today.

How reproducible:

Deterministic.

Steps to Reproduce:
1. Have named search with content on "Custom Search" section.
2. Execute the search and click "Edit Search" at the bottom of the page.

Actual results:

Custom Search section collapsed.

Expected results:

Custom Search section expanded.

Additional info:

Comment 1 Jeff Fearn 🐞 2018-04-03 03:50:53 UTC
It turns out that this is deliberate and controlled by a cookie. Instead of changing this functionality I will change it so it has a visual indication that a section has values selected. This way people who want to hide sections can do so, even if they contain selections.

Comment 2 Jeff Fearn 🐞 2018-04-11 07:00:35 UTC
When a named search is edited then a hollow triangle is shown for collapsed sections that had one or more values set when the form was loaded.

Comment 3 Jeff Fearn 🐞 2018-04-18 10:15:05 UTC
This bug has been resolved in Red Hat Bugzilla 5 and can be tested on https://beta-bugzilla.redhat.com

If there are any issues, do not reopen this bug. Instead, you should create a new bug and reference this bug.


Note You need to log in before you can comment on or make changes to this bug.