Bug 1209398 - virt-viewer --wait option should require a domain name
Summary: virt-viewer --wait option should require a domain name
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-viewer
Version: 6.7
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: rc
: ---
Assignee: Pavel Grunt
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-04-07 09:43 UTC by Pavel Grunt
Modified: 2015-07-22 06:32 UTC (History)
9 users (show)

Fixed In Version: virt-viewer-2.0-5.el6
Doc Type: Bug Fix
Doc Text:
No doc needed
Clone Of:
Environment:
Last Closed: 2015-07-22 06:32:37 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:1322 0 normal SHIPPED_LIVE virt-viewer and spice-gtk bug fix and enhancement update 2015-07-20 17:53:14 UTC

Description Pavel Grunt 2015-04-07 09:43:03 UTC
Description of problem:
virt-viewer waits infinitely when the '--wait' option is used and the domain name is not specified (thus cannot be created)

Version-Release number of selected component (if applicable):
virt-viewer-2.0-2.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1. virt-viewer --wait

Actual results:
a window with text "Waiting for guest domain to be created" pops up, but the domain cannot be created because its name wasn't specified

Expected results:
an error, the '--wait' option should require a domain name

Additional info:
It is regression since it is possible to use virt-viewer without the domain name (commit 88f634179e56742a21fb4c7efc270e4203322d74 )

Comment 4 tingting zheng 2015-04-13 07:33:37 UTC
I can reproduce this bug with:
virt-viewer-2.0-4.el6.x86_64

Tested with:
virt-viewer-2.0-5.el6.x86_64

# virt-viewer --wait
Missing argument for --wait
Run 'virt-viewer --help' to see a full list of available command line options

Refer to the above comments,the bug has been fixed,so move the bug to VERIFIED.

Comment 5 zhoujunqin 2015-04-15 03:17:51 UTC
Since a new fix in virt-viewer for "--wait" option:

https://bugzilla.redhat.com/show_bug.cgi?id=1211573#c2

Test this bug again with new virt-viewer 

virt-viewer-2.0-6.el6.x86_64

1. Check virt-viewer help info

# virt-viewer  --help
...
  -w, --wait                                                        Wait for domain to start
...

2.
# virt-viewer  --wait

No DOMAIN-NAME|ID|UUID was specified for '--wait'

Result: Above result is as expected, '--wait' shouldn't be used without a domain name, keep this bug in VERIFIED status.

Comment 6 Fabiano Fidêncio 2015-04-15 07:41:47 UTC
Changing this behaviour was a command line API breakage.
We decided for reverting the patch to avoid the breakage.

Comment 7 zhoujunqin 2015-04-15 09:12:12 UTC
(In reply to Fabiano Fidêncio from comment #6)
> Changing this behaviour was a command line API breakage.
> We decided for reverting the patch to avoid the breakage.

Hi fidenci, 
I have tested the behavior of "--wait" in bug 1211573 and showing here, thanks.
Test it with new virt-viewer version:

virt-viewer-2.0-6.el6.x86_64

1.
# virt-viewer  --wait --debug

No DOMAIN-NAME|ID|UUID was specified for '--wait'

Result: Error message is expected, to tell user '--wait' shouldn't be used without a domain name.

2.
Running guest:
# virt-viewer  --wait --debug cdrom-rhel6u7-x64

Result: Guest launch with debug information displayed.

Shutdown guest:
virt-viewer window launched and showing "waiting for guest domain for start" and debug info displayed.

3.
Running guest:
# virt-viewer  --debug --wait  cdrom-rhel6u7-x64

Result: Guest launch with debug information displayed.

Shutdown guest: 
virt-viewer window launched and showing "waiting for guest domain for start" and debug info displayed.


4. --wait sequence testing:

Running guest:
# virt-viewer  --wait  cdrom-rhel6u7-x64 
# virt-viewer   cdrom-rhel6u7-x64  --wait

Result: Guest launched successfully.

Shutdown guest: virt-viewer window launched and showing "waiting for guest domain for start"

5. Negative testing
# virt-viewer  --wait=cdrom-rhel6u7-x64 

No DOMAIN-NAME|ID|UUID was specified for '--wait'

All above steps and results are as expected.

Comment 8 errata-xmlrpc 2015-07-22 06:32:37 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1322.html


Note You need to log in before you can comment on or make changes to this bug.