Bug 1209422 - [New] - When user runs remove-brick on a volume he is not allowed to perform status, stop, commit and retain.
Summary: [New] - When user runs remove-brick on a volume he is not allowed to perform ...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin
Version: ---
Hardware: Unspecified
OS: Unspecified
high
high vote
Target Milestone: ovirt-3.6.0-rc
: 3.6.0
Assignee: anmol babu
QA Contact: RamaKasturi
URL:
Whiteboard:
Depends On:
Blocks: rhsc_qe_tracker_everglades
TreeView+ depends on / blocked
 
Reported: 2015-04-07 10:45 UTC by RamaKasturi
Modified: 2016-02-10 12:56 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-02-10 12:56:13 UTC
oVirt Team: Gluster
rule-engine: ovirt-3.6.0+
rule-engine: blocker+
ylavi: planning_ack+
rule-engine: devel_ack+
knarra: testing_ack+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 41528 master MERGED webadmin : Fix Menu Cell click event Never

Description RamaKasturi 2015-04-07 10:45:31 UTC
Description of problem:
When user trues to perform remove-brick operation on a volume, user is not able to perform any other operations like status, commit, stop and retain.

Version-Release number of selected component (if applicable):
ovirt-engine-webadmin-portal-3.6.0-0.0.master.20150406175153.gite240701.el6.noarch

How reproducible:
Always.

Steps to Reproduce:
1. Start remove-brick operation on a volume.
2. click on the drop down to check the status.
3.

Actual results:
Drop down window does not get opened.

Expected results:
Drop down should get opened and user should be able to perform status, retain, stop and commit operations.

Additional info:

Comment 1 RamaKasturi 2015-04-07 12:11:55 UTC
please find the logs attached here.

http://rhsqe-repo.lab.eng.blr.redhat.com/sosreports/rhsc/1209457/

Comment 2 RamaKasturi 2015-04-29 09:19:14 UTC
When rebalance is  run the same issue happens, i.e user is not able to click on the drop down.

Comment 3 Sahina Bose 2015-05-07 11:46:22 UTC
UI widget issue?

Comment 4 anmol babu 2015-05-07 13:37:10 UTC
Yes the issue is in UI menu cell . Recently there was a framework change introduced by Alex, after which this is happening.
I had a conversation in this regard with Alex and he has assured me of helping me
in resolving this.
But, I doubt its appearance in 3.5-gluster as the patch is not in 3.5.

Comment 5 Lubos Trilety 2015-05-20 11:12:41 UTC
(In reply to anmol babu from comment #4)
> Yes the issue is in UI menu cell . Recently there was a framework change
> introduced by Alex, after which this is happening.
> I had a conversation in this regard with Alex and he has assured me of
> helping me
> in resolving this.
> But, I doubt its appearance in 3.5-gluster as the patch is not in 3.5.

It is really working on 3.5 build. Checked with ovirt-engine-3.5.3-0.0.master.20150518010748.git974764e.el6.noarch

Comment 6 anmol babu 2015-05-20 14:58:39 UTC
Thanks Lubos for confirming the same. I will follow up with Greg for a fix in master as well.

Comment 7 Max Kovgan 2015-06-28 14:12:28 UTC
ovirt-3.6.0-3 release

Comment 8 Red Hat Bugzilla Rules Engine 2015-09-22 07:43:34 UTC
This bug report has Keywords: Regression or TestBlocker.
Since no regressions or test blockers are allowed between releases, it is also being identified as a blocker for this release. Please resolve ASAP.

Comment 9 RamaKasturi 2016-02-02 09:27:28 UTC
Tested with RHEV 3.6.2.6 and RHGS Nightly ( glusterfs-3.7.5-17.el7rhgs )

When user performs a remove-brick, user is able to see the drop down menu , check the status of remove brick, commit and retain the bricks.


Note You need to log in before you can comment on or make changes to this bug.