Bug 1209430 - quota/marker: turn off inode quotas by default
Summary: quota/marker: turn off inode quotas by default
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: quota
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Vijaikumar Mallikarjuna
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: qe_tracker_everglades 1218243
TreeView+ depends on / blocked
 
Reported: 2015-04-07 11:03 UTC by Vijaikumar Mallikarjuna
Modified: 2016-06-16 12:47 UTC (History)
5 users (show)

Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1218243 (view as bug list)
Environment:
Last Closed: 2016-06-16 12:47:47 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Vijaikumar Mallikarjuna 2015-04-07 11:03:20 UTC
inode quota is a new feature implemented in glusterfs-3.7
if quota is enabled in the older version and is upgraded
to a new version, we can hit setxattr spike during self-heal
of inode quotas.
So when a quota is enabled, turn off inode-quotas with a xlator option.

With this patch, we still account for inode quotas but only
when a write operation is performed for a particular file.
User will be able to query inode quotas once the inode-quota
xlator option is enabled.

Comment 1 Anand Avati 2015-04-07 11:10:36 UTC
REVIEW: http://review.gluster.org/10152 (quota/marker: turn off inode quota self-heal) posted (#1) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

Comment 2 Anand Avati 2015-04-07 11:11:45 UTC
REVIEW: http://review.gluster.org/10152 (quota/marker: turn off inode quotas by default) posted (#2) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

Comment 3 Anand Avati 2015-04-14 13:22:14 UTC
REVIEW: http://review.gluster.org/10152 (quota/marker: turn off inode quotas by default) posted (#3) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

Comment 4 Anand Avati 2015-04-15 00:37:47 UTC
REVIEW: http://review.gluster.org/10152 (quota/marker: turn off inode quotas by default) posted (#4) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

Comment 5 Anand Avati 2015-04-29 06:39:59 UTC
REVIEW: http://review.gluster.org/10152 (quota/marker: turn off inode quotas by default) posted (#5) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

Comment 6 Anand Avati 2015-04-29 06:58:49 UTC
REVIEW: http://review.gluster.org/10152 (quota/marker: turn off inode quotas by default) posted (#6) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

Comment 7 Anand Avati 2015-04-30 11:24:49 UTC
REVIEW: http://review.gluster.org/10152 (quota/marker: turn off inode quotas by default) posted (#7) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

Comment 8 Anand Avati 2015-05-04 10:36:27 UTC
REVIEW: http://review.gluster.org/10152 (quota/marker: turn off inode quotas by default) posted (#8) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

Comment 9 Anand Avati 2015-05-04 11:51:00 UTC
REVIEW: http://review.gluster.org/10152 (quota/marker: turn off inode quotas by default) posted (#9) for review on master by Sachin Pandit (spandit@redhat.com)

Comment 10 Anand Avati 2015-05-05 10:12:43 UTC
REVIEW: http://review.gluster.org/10152 (quota/marker: turn off inode quotas by default) posted (#10) for review on master by Sachin Pandit (spandit@redhat.com)

Comment 11 Anand Avati 2015-05-06 05:37:13 UTC
REVIEW: http://review.gluster.org/10152 (quota/marker: turn off inode quotas by default) posted (#11) for review on master by Sachin Pandit (spandit@redhat.com)

Comment 12 Anand Avati 2015-05-06 08:53:24 UTC
REVIEW: http://review.gluster.org/10152 (quota/marker: turn off inode quotas by default) posted (#12) for review on master by Sachin Pandit (spandit@redhat.com)

Comment 13 Anand Avati 2015-05-06 17:49:12 UTC
COMMIT: http://review.gluster.org/10152 committed in master by Vijay Bellur (vbellur@redhat.com) 
------
commit b054985d2f7db9ab72759c988db11feb855a1b5e
Author: vmallika <vmallika@redhat.com>
Date:   Thu Apr 30 16:50:47 2015 +0530

    quota/marker: turn off inode quotas by default
    
    inode quota is a new feature implemented in glusterfs-3.7
    if quota is enabled in the older version and is upgraded
    to a new version, we can hit setxattr spike during self-heal
    of inode quotas. So, when a quota is enabled, turn off
    inode-quotas with a xlator option.
    
    With this patch, we still account for inode quotas but only
    when a write operation is performed for a particular file.
    User will be able to query inode quotas once the Inode-quota
    xlator option is enabled.
    
    Change-Id: I52fb28bf7024989ce7bb08ac63a303bf3ec1ec9a
    BUG: 1209430
    Signed-off-by: vmallika <vmallika@redhat.com>
    Signed-off-by: Sachin Pandit <spandit@redhat.com>
    Reviewed-on: http://review.gluster.org/10152
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>

Comment 14 Nagaprasad Sathyanarayana 2015-10-25 15:02:26 UTC
Fix for this BZ is already present in a GlusterFS release. You can find clone of this BZ, fixed in a GlusterFS release and closed. Hence closing this mainline BZ as well.

Comment 15 Niels de Vos 2016-06-16 12:47:47 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.