Bug 120953 - Add NFS client (and server) to default kernel configuration
Add NFS client (and server) to default kernel configuration
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: nfs-utils (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Steve Dickson
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-15 12:28 EDT by John S. Monaco
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-14 16:54:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John S. Monaco 2004-04-15 12:28:46 EDT
Description of problem:

Despite the fact that NFS is enabled, you can't actually mount
anything over a network.

Version-Release number of selected component (if applicable):

kernel-2.6.5-1.322.i686.rpm

How reproducible:

Very

Steps to Reproduce:

1.# chkconfig --list nfs
  nfs             0:off   1:off   2:off   3:on    4:on    5:on    6:off

2.mkdir /mnt/test_mount

3.# mount -v 192.168.2.1:/test_mount /mnt/test_mount
  mount: no type was given - I'll assume nfs because of the colon
  mount: fs type nfs not supported by kernel
  
Actual results:

NFS mount was not successful.

Expected results:

NFS mount would have succeeded.

Additional info:

I did a "make defconfig", and noticed that NFSv3 client and server are
not enabled filesystems by default.
Comment 1 Sahil Verma 2004-04-16 19:16:01 EDT
You'll probably have to bug upstream to change defconfig.
Comment 2 John S. Monaco 2004-04-28 12:45:10 EDT
I am continually doing research on this bug, because it made no sense
that it has gone un-noticed by everyone else. Come to find out, in the
%post section of my ks.cfg, I had the following command:

# chkconfig --level 345 nfs on

So, if I do a build with the above command commented out, after a
reboot, I see this:

1.# chkconfig --list nfs
  nfs             0:off   1:off   2:off   3:off    4:off    5:off    6:off

... but guess what? NFS does actually work! It's only when you enable
it, that it stops working.

Sorry for the bad information in my original bug report.
Comment 3 Steve Dickson 2004-10-14 16:54:54 EDT
It does not appear that this is a issue, please 
reopen if it is...

Note You need to log in before you can comment on or make changes to this bug.