Bug 1209550 - Disabling one but last display changes resolution of the first display
Summary: Disabling one but last display changes resolution of the first display
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: spice-vdagent
Version: 6.7
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Default Assignee for SPICE Bugs
QA Contact: SPICE QE bug list
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-04-07 15:52 UTC by Pavel Grunt
Modified: 2015-07-22 07:28 UTC (History)
6 users (show)

(edit)
Cause: Resolution changes weren't always stored

Consequence: The first display resizes after another display is disabled

Fix: Store resolutions of all displays

Result: The first display keeps the expected resolution
Clone Of:
(edit)
Last Closed: 2015-07-22 07:28:14 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:1392 normal SHIPPED_LIVE spice-vdagent bug fix update 2015-07-20 17:58:05 UTC

Description Pavel Grunt 2015-04-07 15:52:45 UTC
Description of problem:


Version-Release number of selected component (if applicable):
spice-vdagent-0.14.0-5.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1. connect to rhel6 guest which has one display using virt-viewer
2. resize virt-viewer's window to increase resolution of the guest
3. enable second display
4. disable second display

Actual results:
the first display changes resolution

Expected results:
the resolution remains the same

Additional info:
Working as expected with upstream version of vdagent since commit 9ae51f3702b1fc0d2747e44474c87a818d1e8ec3

Comment 3 errata-xmlrpc 2015-07-22 07:28:14 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1392.html


Note You need to log in before you can comment on or make changes to this bug.