Bug 1209602 - Creating a database server role instance doesn't set the password for the owner
Summary: Creating a database server role instance doesn't set the password for the owner
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: rolekit
Version: 22
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
Assignee: Thomas Woerner
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker
Depends On:
Blocks: F22BetaBlocker
TreeView+ depends on / blocked
 
Reported: 2015-04-07 18:05 UTC by Stephen Gallagher
Modified: 2015-04-17 02:29 UTC (History)
5 users (show)

Fixed In Version: rolekit-0.3.2-1.fc22
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-04-17 02:29:44 UTC
Type: Bug


Attachments (Terms of Use)

Description Stephen Gallagher 2015-04-07 18:05:24 UTC
Description of problem:
Deploying a Database Server Role in Fedora 22 Server Beta TC8 fails to create an instance that is reachable by external services. The password is not set on the owner (user) of the database.

Version-Release number of selected component (if applicable):
rolekit-0.3.1-1.fc22

How reproducible:
Every time

Steps to Reproduce:
1. Install Fedora Server
2. Run 'rolectl deploy --settings-file=db.json databaseserver' with the following contents of db.json:
{
    "database": "any_name",
    "owner": "db_owner",
    "password": "my_password"
}

3. Attempt to log into the database using:
psql -U db_owner -d any_name -h localhost

Actual results:
The password is rejected. Checking /var/lib/pgsql/data/pg_log/* shows that the user has no password set.

Expected results:
The user should be presented with the PostgreSQL CLI shell.

Additional info:

Comment 1 Fedora Blocker Bugs Application 2015-04-07 18:07:36 UTC
Proposed as a Blocker for 22-beta by Fedora user sgallagh using the blocker tracking app because:

 "The core functional requirements for all Featured Server Roles must be met, without any workarounds being necessary."

From core functional requirements of the DB Server Role: "The core command line utilities for PostgreSQL must be available and correctly handle ... Basic SQL interactions, including creation, modification, deletion, and simple querying of users, tables, columns, and rows."

Comment 2 Fedora Update System 2015-04-07 18:09:14 UTC
rolekit-0.3.2-1.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/FEDORA-2015-4922/rolekit-0.3.2-1.fc22

Comment 3 Adam Williamson 2015-04-07 18:10:06 UTC
+1 blocker.

Comment 4 Kevin Fenzi 2015-04-07 21:32:02 UTC
+1 blocker.

Comment 5 Fedora Update System 2015-04-08 18:37:19 UTC
Package rolekit-0.3.2-1.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing rolekit-0.3.2-1.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-4922/rolekit-0.3.2-1.fc22
then log in and leave karma (feedback).

Comment 6 Adam Williamson 2015-04-10 04:27:36 UTC
Discussed at 2015-04-09 Go/No-Go meeting, acting as a blocker review meeting: https://meetbot.fedoraproject.org/fedora-meeting-2/2015-04-09/f22_beta_gono-go_meeting.2015-04-09-17.00.html . Accepted as a Beta blocker, per criterion cited in #c1.

Comment 7 Fedora Update System 2015-04-17 02:29:44 UTC
rolekit-0.3.2-1.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.