Bug 120962 - locking type 1 initialization failed
Summary: locking type 1 initialization failed
Status: CLOSED DUPLICATE of bug 120595
Alias: None
Product: Fedora
Classification: Fedora
Component: policy   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: FC2Blocker
TreeView+ depends on / blocked
 
Reported: 2004-04-15 17:08 UTC by Gene Czarcinski
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:02:36 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Gene Czarcinski 2004-04-15 17:08:54 UTC
Description of problem:

After updating to latest lvm2, I get "locaking type 1 initialization
failed ... /var/lock/lvm failed, access denied.

Version-Release number of selected component (if applicable):
lvm2-2.00.12-1.0
policy-1.11.2-6

The following is from /var/log/messages:

Apr 15 12:46:54 chaos kernel: audit(1082047579.265:0): avc:  denied  {
create } for  pid=126 exe=/sbin/lvm.static name=lvm
scontext=system_u:system_r:lvm_t tcontext=system_u:object_r:var_lock_t
tclass=dir

Comment 1 Stephen Tweedie 2004-04-15 18:55:29 UTC
Looks like a policy problem at heart.

Comment 2 Gene Czarcinski 2004-04-15 19:07:40 UTC
I thought it might be but was not sure (that is why I had cc'ec him on
the original report).  I doubt he needs two copies of each update so I
am deleting him from the CC list.

Comment 3 Daniel Walsh 2004-04-16 11:03:33 UTC
Fixed in policy-1.11.2-9

Comment 4 Gene Czarcinski 2004-04-16 21:17:15 UTC
This one is not a winner ... update to lvm2-2.00-12-4 and
policy-1.11.2-9 and still get the initialzation failure.

I am not currently using lvm so this does not bother me too much.

/var/log/messages:
Apr 16 17:09:13 chaos kernel: audit(1082149721.992:0): avc:  denied  {
create } for  pid=314 exe=/sbin/lvm.static name=lvm
scontext=system_u:system_r:lvm_t tcontext=system_u:object_r:var_lock_t
tclass=dir


ls -Z /var
drwxrwxr-x  root     lock     system_u:object_r:var_lock_t     lock

Comment 5 Colin Walters 2004-04-20 21:01:57 UTC

*** This bug has been marked as a duplicate of 120595 ***

Comment 6 Red Hat Bugzilla 2006-02-21 19:02:36 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.