Bug 1209649 - [UX] dnf group info (and other two word commands) give wrong mini_usage info
[UX] dnf group info (and other two word commands) give wrong mini_usage info
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
22
All Linux
low Severity low
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-04-07 18:00 EDT by Quentin Armitage
Modified: 2016-04-13 03:22 EDT (History)
8 users (show)

See Also:
Fixed In Version: dnf-1.1.8-1.fc24 dnf-1.1.8-1.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-13 03:22:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Quentin Armitage 2015-04-07 18:00:01 EDT
Description of problem:
Wrong mini-usage output for dnf group info

Version-Release number of selected component (if applicable):
dnf-0.6.5-1.fc22

How reproducible:
Always

Steps to Reproduce:
1. dnf group info
2.
3.

Actual results:
# yum group info
Loaded plugins: langpacks, refresh-packagekit
Error: Need a group or list of groups

 Mini usage:

info [PACKAGE|all|available|installed|updates|distro-extras|extras|obsoletes|recent]

Display details about a package or group of packages


Expected results:
# yum group info
Loaded plugins: langpacks, refresh-packagekit
Error: Need a group or list of groups

 Mini usage:

group info GROUP

Display details about a group or groups.

Additional info:
The output is the mini_usage for "dnf info", as opposed to "dnf group info".
The reason for this is that _err_mini_usage is called with basecmd = 'info' whereas the basecmd should be 'group', but the mini_usage should be in the context of the subcommand 'info' for the 'group' basecmd, and there appears to be no mechanism to handle mini_usage for subcommands.

The same problem occurs with yum.
Comment 1 Honza Silhan 2015-04-09 10:45:48 EDT
Thanks for the report, we'll take a look.
Comment 2 Fedora Update System 2016-04-06 10:39:02 EDT
dnf-plugins-core-0.1.20-1.fc24 dnf-1.1.8-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-5dae5d2add
Comment 3 Fedora Update System 2016-04-07 06:02:22 EDT
dnf-1.1.8-1.fc23 dnf-plugins-core-0.1.20-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-ddeabfcfe6
Comment 4 Fedora Update System 2016-04-07 12:54:32 EDT
dnf-1.1.8-1.fc24, dnf-plugins-core-0.1.20-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-5dae5d2add
Comment 5 Fedora Update System 2016-04-08 12:59:23 EDT
dnf-1.1.8-1.fc24, dnf-plugins-core-0.1.20-1.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.
Comment 6 Fedora Update System 2016-04-08 16:51:42 EDT
dnf-1.1.8-1.fc23, dnf-plugins-core-0.1.20-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-ddeabfcfe6
Comment 7 Fedora Update System 2016-04-13 03:21:48 EDT
dnf-1.1.8-1.fc23, dnf-plugins-core-0.1.20-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.