Bug 1209654 - jsoncpp-1.6.5 is available
Summary: jsoncpp-1.6.5 is available
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: jsoncpp
Version: rawhide
Hardware: All
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Björn 'besser82' Esser
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-04-07 23:03 UTC by Quentin Armitage
Modified: 2016-04-02 16:44 UTC (History)
6 users (show)

Fixed In Version: jsoncpp-1.7.2-1.fc24
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-04-02 16:44:01 UTC


Attachments (Terms of Use)

Description Quentin Armitage 2015-04-07 23:03:10 UTC
Description of problem:
jsoncpp has moved from Sourceforce to github, and is now at version 1.6.1. There has been a substantial number of updates since 0.6.0-rc2.

Version-Release number of selected component (if applicable):
jsoncpp-0.6.0-0.14.rc2.fc22.x86_64

How reproducible:
N/a

Steps to Reproduce:
1. n/a
2.
3.

Actual results:


Expected results:


Additional info:
The new homepage for jsoncpp is https://github.com/open-source-parsers/jsoncpp

Comment 1 Matthew Miller 2015-05-29 13:53:52 UTC
Note that there is also a backwards compatible 0.10.x branch — suggest updating to that. I made an updated specfile in bug #1143774:


Spec: http://mattdm.org/misc/fedora/jsoncpp.spec
SRPM: http://mattdm.org/misc/fedora/jsoncpp-0.10.0-1.src.rpm

but these should be updated to 0.10.2 (or whatever is current).

Comment 2 Christopher Meng 2015-08-21 11:35:25 UTC
Please use 0.10 branch for f24 and move to 1.x from f25(if possible push to f24 as well). 

I'd like to see 0.10 in f23, because Fedora jsoncpp has been outdated for years. 

And my idea of this is that since we have switched cxx standard used in gcc, 1.x is better.

Comment 3 Peter Robinson 2015-09-08 12:30:53 UTC
Sebastien: any update? You moved it to assigned in April and there doesn't appear to have been any movement since.

Comment 4 Sébastien Willmann 2015-09-13 20:05:11 UTC
Sorry for doing this so late. I just built jsoncpp 0.10.5 for rawhide. Should I leave this bug open until I move to 1.x in f25?

Comment 5 Orion Poplawski 2015-09-14 04:07:22 UTC
FYI - koschei is now reporting build failures for paraview (at least on arm) with this, so it's not entirely API compatible it seems:

/builddir/build/BUILD/ParaView-v4.3.1-source/ParaViewCore/ServerManager/Core/vtkSMSettings.cxx: In member function 'const Json::Value& vtkSMSettings::vtkSMSettingsInternal::GetSettingBelowPriority(const char*, double)':
/builddir/build/BUILD/ParaView-v4.3.1-source/ParaViewCore/ServerManager/Core/vtkSMSettings.cxx:150:12: error: 'null' is not a member of 'Json::Value'
     return Json::Value::null;
            ^
/builddir/build/BUILD/ParaView-v4.3.1-source/ParaViewCore/ServerManager/Core/vtkSMSettings.cxx: In member function 'const Json::Value& vtkSMSettings::vtkSMSettingsInternal::GetSettingAtOrBelowPriority(const char*, double)':
/builddir/build/BUILD/ParaView-v4.3.1-source/ParaViewCore/ServerManager/Core/vtkSMSettings.cxx:177:12: error: 'null' is not a member of 'Json::Value'
     return Json::Value::null;
            ^
/builddir/build/BUILD/ParaView-v4.3.1-source/ParaViewCore/ServerManager/Core/vtkSMSettings.cxx: In member function 'void vtkSMSettings::vtkSMSettingsInternal::SetSetting(const char*, const std::vector<T>&)':
/builddir/build/BUILD/ParaView-v4.3.1-source/ParaViewCore/ServerManager/Core/vtkSMSettings.cxx:484:23: error: 'null' is not a member of 'Json::Value'
     jsonValue[leaf] = Json::Value::null;
                       ^
/builddir/build/BUILD/ParaView-v4.3.1-source/ParaViewCore/ServerManager/Core/vtkSMSettings.cxx: In member function 'void vtkSMSettings::SetSettingDescription(const char*, const char*)':
/b

Comment 6 Orion Poplawski 2015-09-17 21:55:57 UTC
  static const Value& nullRef;
#if !defined(__ARMEL__)
  /// \deprecated This exists for binary compatibility only. Use nullRef.
  static const Value null;
#endif

So, looks like paraview should be using nullRef.

Comment 7 Christopher Meng 2015-09-18 04:00:03 UTC
(In reply to Orion Poplawski from comment #6)
>   static const Value& nullRef;
> #if !defined(__ARMEL__)
>   /// \deprecated This exists for binary compatibility only. Use nullRef.
>   static const Value null;
> #endif
> 
> So, looks like paraview should be using nullRef.


Yes, just a small substitution I think.

Comment 8 Orion Poplawski 2015-09-18 04:04:51 UTC
Yup, that appears to have worked.

Comment 9 Christopher Meng 2015-09-18 04:09:18 UTC
(In reply to Sébastien Willmann from comment #4)
> Sorry for doing this so late. I just built jsoncpp 0.10.5 for rawhide.
> Should I leave this bug open until I move to 1.x in f25?

Up to you.

What I'm concerned about, is jsoncpp in EPEL7. EPEL6 uses an ancient version, while EPEL7 still ships it...

ALSO, I just went through sources, and found the upstream had merged pkgconfig and cmake support, soname is now handled by upstream, in both 0.x.y and master. You shouldn't use 0.0.0 anymore.

Comment 10 Orion Poplawski 2015-09-20 13:52:10 UTC
Hmm, epel7 will be tricky.  Also, be aware that upstream does not appear to be very good about catching/tracking API/ABI changes: http://upstream.rosalinux.ru/versions/jsoncpp.html

Comment 11 Sébastien Willmann 2016-01-03 18:13:49 UTC
I updated the package to use cmake instead of scons.

Comment 12 Björn 'besser82' Esser 2016-03-26 10:44:55 UTC
I just coordinated an update to jsoncpp-1.7.2 for fc24+ with Sebastien.

The update bumps the so-name to libjsoncpp.so.1, but keeps 100% source-compatibility to 0.10.5, binary-wise there are 5 new symbols and 2 symbols are renamed by C++ mangling.  Rebuilds are already running (and already finished for Rawhide).

I'll tag all rebuilt packages into buildroot-overrides on fc24 and will provide a multi-binary update as soon as the builds are finished.

Comment 13 Fedora Update System 2016-03-26 12:06:38 UTC
cmake-3.5.1-1.fc24 jsoncpp-1.7.2-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-3353070273

Comment 14 Fedora Update System 2016-03-26 12:06:46 UTC
cmake-3.5.1-1.fc24 jsoncpp-1.7.2-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-3353070273

Comment 15 Fedora Update System 2016-03-26 23:52:47 UTC
cmake-3.5.1-1.fc24, jsoncpp-1.7.2-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-3353070273

Comment 16 Fedora Update System 2016-03-27 06:37:38 UTC
cmake-3.5.1-2.fc24 jsoncpp-1.7.2-1.fc24 orthanc-0.8.6-8.fc24 vfrnav-20160212-2.fc24 vtk-6.3.0-7.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-3353070273

Comment 17 Fedora Update System 2016-03-27 21:50:46 UTC
cmake-3.5.1-2.fc24, engrid-2.0.0-0.12.gitbaef0ce.fc24, jsoncpp-1.7.2-1.fc24, orthanc-0.8.6-8.fc24, paraview-5.0.1-0.3.RC2.fc24, vfrnav-20160212-2.fc24, vtk-6.3.0-7.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-3353070273

Comment 18 Fedora Update System 2016-03-28 07:45:39 UTC
cmake-3.5.1-2.fc24 engrid-2.0.0-0.12.gitbaef0ce.fc24 jsoncpp-1.7.2-1.fc24 mrpt-1.3.2-4.fc24 orthanc-0.8.6-8.fc24 paraview-5.0.1-0.3.RC2.fc24 pcl-1.8.0-0.3.rc1.fc24 vfrnav-20160212-2.fc24 vtk-6.3.0-7.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-3353070273

Comment 19 Fedora Update System 2016-03-28 20:55:30 UTC
cmake-3.5.1-2.fc24, engrid-2.0.0-0.12.gitbaef0ce.fc24, jsoncpp-1.7.2-1.fc24, mrpt-1.3.2-4.fc24, orthanc-0.8.6-8.fc24, paraview-5.0.1-0.3.RC2.fc24, pcl-1.8.0-0.3.rc1.fc24, vfrnav-20160212-2.fc24, vtk-6.3.0-7.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-3353070273

Comment 20 Fedora Update System 2016-03-29 08:03:47 UTC
cmake-3.5.1-2.fc24 engrid-2.0.0-0.12.gitbaef0ce.fc24 jsoncpp-1.7.2-1.fc24 kopete-15.12.3-2.fc24 minetest-0.4.13-5.fc24 mrpt-1.3.2-4.fc24 orthanc-0.8.6-8.fc24 paraview-5.0.1-0.3.RC2.fc24 passenger-5.0.26-2.fc24 pcl-1.8.0-0.3.rc1.fc24 vfrnav-20160212-2.fc24 vtk-6.3.0-7.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-3353070273

Comment 21 Fedora Update System 2016-03-30 00:28:35 UTC
cmake-3.5.1-2.fc24, engrid-2.0.0-0.12.gitbaef0ce.fc24, jsoncpp-1.7.2-1.fc24, kopete-15.12.3-2.fc24, minetest-0.4.13-5.fc24, mrpt-1.3.2-4.fc24, orthanc-0.8.6-8.fc24, paraview-5.0.1-0.3.RC2.fc24, passenger-5.0.26-2.fc24, pcl-1.8.0-0.3.rc1.fc24, vfrnav-20160212-2.fc24, vtk-6.3.0-7.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-3353070273

Comment 22 Fedora Update System 2016-04-02 16:43:35 UTC
cmake-3.5.1-2.fc24, engrid-2.0.0-0.12.gitbaef0ce.fc24, jsoncpp-1.7.2-1.fc24, kopete-15.12.3-2.fc24, minetest-0.4.13-5.fc24, mrpt-1.3.2-4.fc24, orthanc-0.8.6-8.fc24, paraview-5.0.1-0.3.RC2.fc24, passenger-5.0.26-2.fc24, pcl-1.8.0-0.3.rc1.fc24, vfrnav-20160212-2.fc24, vtk-6.3.0-7.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.