Bug 1209708 - floppy fail to be accessible(Location is not available) after change from none
Summary: floppy fail to be accessible(Location is not available) after change from none
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm-rhev
Version: 7.2
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: ---
Assignee: John Snow
QA Contact: FuXiangChun
URL:
Whiteboard:
Depends On: 1209362 1209707
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-04-08 03:16 UTC by Sibiao Luo
Modified: 2016-11-07 20:22 UTC (History)
16 users (show)

Fixed In Version: qemu-2.6.0
Doc Type: Bug Fix
Doc Text:
Clone Of: 1209707
Environment:
Last Closed: 2016-11-07 20:22:23 UTC


Attachments (Terms of Use)
screenshot_for_qemu-kvm-rhev-2.2.0-8.el7.x86_64 (113.26 KB, image/png)
2015-04-08 03:17 UTC, Sibiao Luo
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2673 normal SHIPPED_LIVE qemu-kvm-rhev bug fix and enhancement update 2016-11-08 01:06:13 UTC

Comment 1 Sibiao Luo 2015-04-08 03:17:09 UTC
Created attachment 1012009 [details]
screenshot_for_qemu-kvm-rhev-2.2.0-8.el7.x86_64

Comment 2 Sibiao Luo 2015-04-08 03:18:04 UTC
host info:
# uname -r&& rpm -q qemu-kvm-rhev
3.10.0-232.el7.x86_64
qemu-kvm-rhev-2.2.0-8.el7.x86_64
guest info:
# rpm -q virtio-win
virtio-win-1.7.2-2.el6.noarch
/usr/share/virtio-win/virtio-win-1.7.2_amd64.vfd

Comment 4 John Snow 2015-06-30 20:01:43 UTC
The problem is caused by QEMU's usage of the 1.44MB FDrive type as a default when no floppy is inserted. Our virtio-win drivers ship on a 2.88MB floppy drive image. There is currently no CLI interface to specify that a 2.88MB drive is desired, except by having an image present at boot.

I am delaying this BZ because it needs to be worked on upstream and will likely involve more research before a proper fix is identified.

I recommend releasing documentation informing users that it would be best to boot their machine with a 2.88MB FD image if they desire that functionality. In this particular case, this image is generally only useful at boot during a new VM installation, so impact is expected to be minimal.

Comment 6 John Snow 2016-05-16 18:14:56 UTC
Should be fixed by rebase to 2.6.0.

Comment 8 FuXiangChun 2016-09-13 07:51:50 UTC
according to comment0. reproduced but with qemu-kvm-rhev-2.3.0-31. 

verified this but with 3:qemu-kvm-rhev-2.6.0-23.el7

Comment 10 errata-xmlrpc 2016-11-07 20:22:23 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2673.html


Note You need to log in before you can comment on or make changes to this bug.