Bug 1209798 - migration: 7.2->7.1 qemu-kvm: Unknown ramblock "/rom@etc/acpi/rsdp", cannot accept migration (7.2 machine type)
Summary: migration: 7.2->7.1 qemu-kvm: Unknown ramblock "/rom@etc/acpi/rsdp", cannot a...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm-rhev
Version: 7.2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Dr. David Alan Gilbert
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks: 1174920 1191307 1209300
TreeView+ depends on / blocked
 
Reported: 2015-04-08 08:57 UTC by Dr. David Alan Gilbert
Modified: 2016-11-29 08:52 UTC (History)
8 users (show)

Fixed In Version: qemu-kvm-rhev-2.3.0-1.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-12-04 16:34:10 UTC
Target Upstream Version:


Attachments (Terms of Use)
xml for broken vm (3.64 KB, text/html)
2015-04-08 08:57 UTC, Dr. David Alan Gilbert
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:2546 normal SHIPPED_LIVE qemu-kvm-rhev bug fix and enhancement update 2015-12-04 21:11:56 UTC

Description Dr. David Alan Gilbert 2015-04-08 08:57:47 UTC
Created attachment 1012115 [details]
xml for broken vm

Description of problem:

Migrating 7.1->7.2->7.1 and hit:
qemu-kvm: Unknown ramblock "/rom@etc/acpi/rsdp", cannot accept migration
Version-Release number of selected component (if applicable):


How reproducible:
unknown

Steps to Reproduce:
1.
2.
3.

Actual results:
qemu-kvm: Unknown ramblock "/rom@etc/acpi/rsdp", cannot accept migration

Expected results:
working migration

Additional info:
/usr/libexec/qemu-kvm -name f20-414 -S -machine pc-i440fx-rhel7.1.0,accel=kvm,usb=off -cpu SandyBridge -m 2048 -realtime mlock=off -smp 2,sockets=2,cores=1,threads=1 -uuid eb42c9ed-4c2b-496d-b415-e1e1cc2a917e -no-user-config -nodefaults -chardev socket,id=charmonitor,path=/var/lib/libvirt/qemu/f20-414.monitor,server,nowait -mon chardev=charmonitor,id=monitor,mode=control -rtc base=utc,driftfix=slew -global kvm-pit.lost_tick_policy=discard -no-hpet -no-shutdown -global PIIX4_PM.disable_s3=1 -global PIIX4_PM.disable_s4=1 -boot strict=on -device ich9-usb-ehci1,id=usb,bus=pci.0,addr=0x5.0x7 -device ich9-usb-uhci1,masterbus=usb.0,firstport=0,bus=pci.0,multifunction=on,addr=0x5 -device ich9-usb-uhci2,masterbus=usb.0,firstport=2,bus=pci.0,addr=0x5.0x1 -device ich9-usb-uhci3,masterbus=usb.0,firstport=4,bus=pci.0,addr=0x5.0x2 -device virtio-serial-pci,id=virtio-serial0,bus=pci.0,addr=0x6 -drive file=/home/vms/f20.qcow2,if=none,id=drive-virtio-disk0,format=qcow2,cache=none -device virtio-blk-pci,scsi=off,bus=pci.0,addr=0x7,drive=drive-virtio-disk0,id=virtio-disk0,bootindex=1 -netdev tap,fd=23,id=hostnet0,vhost=on,vhostfd=24 -device virtio-net-pci,netdev=hostnet0,id=net0,mac=52:54:00:bc:51:1a,bus=pci.0,addr=0x3 -chardev pty,id=charserial0 -device isa-serial,chardev=charserial0,id=serial0 -chardev socket,id=charchannel0,path=/var/lib/libvirt/qemu/channel/target/f20-414.org.qemu.guest_agent.0,server,nowait -device virtserialport,bus=virtio-serial0.0,nr=1,chardev=charchannel0,id=channel0,name=org.qemu.guest_agent.0 -chardev spicevmc,id=charchannel1,name=vdagent -device virtserialport,bus=virtio-serial0.0,nr=2,chardev=charchannel1,id=channel1,name=com.redhat.spice.0 -device usb-tablet,id=input0 -vnc 127.0.0.1:0 -device cirrus-vga,id=video0,bus=pci.0,addr=0x2 -chardev spicevmc,id=charredir0,name=usbredir -device usb-redir,chardev=charredir0,id=redir0 -chardev spicevmc,id=charredir1,name=usbredir -device usb-redir,chardev=charredir1,id=redir1 -incoming tcp:[::]:49152 -device virtio-balloon-pci,id=balloon0,bus=pci.0,addr=0x8 -msg timestamp=on

Comment 3 Dr. David Alan Gilbert 2015-05-05 10:28:58 UTC
This should have been fixed as part of bz 1210050 (adding new machine type)

Comment 7 huiqingding 2015-07-08 08:30:32 UTC
Test this bug using the command line of comment #5 and following version:
RHEL7.1 host:
kernel-3.10.0-229.7.2.el7.x86_64
qemu-kvm-rhev-2.1.2-23.el7_1.4.x86_64
RHEL7.2 host:
kernel-3.10.0-287.el7.x86_64
qemu-img-rhev-2.3.0-6.el7.x86_64

1) Do migration 7.1->7.2->7.1, the migration can be finished normally.

2) Do migration 7.2->7.1, the migration can be finished normally.

Comment 10 errata-xmlrpc 2015-12-04 16:34:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2546.html


Note You need to log in before you can comment on or make changes to this bug.