Bug 12098 - pwck should allow #comments in /etc/passwd
pwck should allow #comments in /etc/passwd
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: shadow-utils (Show other bugs)
6.2
All Linux
low Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-06-11 17:03 EDT by Jean Berthomieu
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-06-15 17:10:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jean Berthomieu 2000-06-11 17:03:15 EDT
We are working in a university where main servers define lots of users in a
single /etc/passwd. Then they are shared to many NIS clients. 
We used to group them and to put some comment lines to explain which groups
were for what... Sometimes, we just comment some user out, in case it could
come back. 
Then we would like to use "pwck" to check that everything was right, but we
got lots of errors because of those comments.
We checked that /var/yp/Makefile did allow comments lines beginning with
"#" and empty lines in source files, as they were harmless in local
processing too. So, why "pwck" is so restrictive about them ?
Comment 1 Bernhard Rosenkraenzer 2000-06-15 17:10:24 EDT
The various standards don't allow for comments and empty lines
in password files, so pwck is correct in complaining about them.
Using comments in password files may or may not work with any other
operating systems or even with updates, so keeping this check in is
actually a good thing.
Comment 2 Jean Berthomieu 2000-06-16 05:12:15 EDT
"Tell us what you need, we'll tell you how to do without!" :-(

Maybe "other operating systems" don't allow comments in password file
(Windows?), but I thought we had to do with *RedHat Linux* which, AFAIK does
allow them. 

I could imagine that it would have been nice - in a next release, for an
enhancement - to provide some switch to allow them "a la RedHat". Maybe, I'll
get a better luck from Mandrake?

Note You need to log in before you can comment on or make changes to this bug.