Bug 1209864 - The orphans plugin reports things as orphans that aren't
The orphans plugin reports things as orphans that aren't
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dnf-plugins-extras (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Igor Gnatenko
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-04-08 07:21 EDT by Tom Hughes
Modified: 2015-04-27 04:47 EDT (History)
10 users (show)

See Also:
Fixed In Version: dnf-plugins-extras-0.0.7-1.fc22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-04-27 04:47:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom Hughes 2015-04-08 07:21:39 EDT
Description of problem:

We ask for orphans:

fedora22 [~] % sudo dnf orphans
CharLS-devel-1.0-8.fc22.x86_64
<...another 587 lines...>
zsh-5.0.7-6.fc22.x86_64

But when we check those packages do exist in configured repositories:

fedora22 [~] % sudo dnf list --showduplicates zsh
Using metadata from Wed Apr  8 11:02:28 2015 (0:53:45 hours old)
Installed Packages
zsh.x86_64                       5.0.7-6.fc22                        @System    
Available Packages
zsh.x86_64                       5.0.7-6.fc22                        @System    
zsh.x86_64                       5.0.7-6.fc22                        fedora-base

Version-Release number of selected component (if applicable):

python-dnf-plugins-extras-orphans-0.0.6-2.fc22.noarch
Comment 1 Michael Schröder 2015-04-08 11:51:11 EDT
I think "orphans" is not a good name for that plugin, people expect it to do something else. All it does is 'List installed packages not required by any other package'...

(It does not even look at the userinstalled bit.)
Comment 2 Michael Mráka 2015-04-08 12:01:25 EDT
Maybe you wanted to use

dnf list extras
              Lists  extras,  that  is  packages  installed on the system that are not available in any known repository.

Does this solve your use case?
Comment 3 Mace Moneta 2015-04-08 12:07:15 EDT
I think the problem is the inconsistent terminology between yum and dnf.

DNF extras are what yum calls orphans.
DNF orphans are what yum calls leaves (leaf packages).
Comment 4 Tom Hughes 2015-04-08 12:10:03 EDT
Yes it sounds like extras is what I wanted. I think I just googled "dnf orphans" to find a replacement for "package-cleanup --orphans" and got http://rpm.pbone.net/index.php3/stat/45/idpl/29084811/numer/8/nazwa/dnf.plugin.orphans which doesn't actually say much but seemed like a plausible replacement.
Comment 5 Radek Holy 2015-04-09 02:57:04 EDT
(In reply to Mace Moneta from comment #3)
> I think the problem is the inconsistent terminology between yum and dnf.
> 
> DNF extras are what yum calls orphans.
> DNF orphans are what yum calls leaves (leaf packages).

More precisely, when I was implementing "dnf list extras", I followed "yum list" which calls it "extras" too. So if YUM calls it "orphans" elsewhere, it's more about inconsistency within YUM which we more or less have to inherit in favour of compatibility.

And "dnf orphans" is part of dnf-plugins-extras which is a community project that is not under control of DNF developers so I'd rather say that it's about inconsistency between DNF and dnf-plugins-extras.

But sure, in the end, the user does not care and we should cooperate in order to improve their experience.
Comment 6 Tom Hughes 2015-04-09 03:19:27 EDT
I guess yum must have added that, with a different name, as a core feature after package-cleanup already had it. I certainly was aware that "yum list extras" existed and have always used "package-cleanup --orphans".
Comment 7 Michael Mráka 2015-04-09 03:36:23 EDT
Radek and Igor, can we agree on renaming orphans plugin and command to 'leaves' - to make it less confusing and more cosistent with yum's naming in use?
Comment 8 Radek Holy 2015-04-09 03:42:31 EDT
I have no strong opinion on that. I am not involved in the plugin. But I guess that "leaves" really sounds better.
Comment 10 Fedora Update System 2015-04-21 08:24:26 EDT
dnf-plugins-extras-0.0.7-1.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/dnf-plugins-extras-0.0.7-1.fc22
Comment 11 Fedora Update System 2015-04-22 18:48:08 EDT
Package dnf-plugins-extras-0.0.7-1.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dnf-plugins-extras-0.0.7-1.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-6624/dnf-plugins-extras-0.0.7-1.fc22
then log in and leave karma (feedback).
Comment 12 Fedora Update System 2015-04-27 04:47:17 EDT
dnf-plugins-extras-0.0.7-1.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.