Bug 1209927 - Geolocation is broken and default language is always used
Summary: Geolocation is broken and default language is always used
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 22
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Martin Kolman
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedFreezeException https://fedor...
Depends On:
Blocks: F22BetaFreezeException
TreeView+ depends on / blocked
 
Reported: 2015-04-08 13:03 UTC by Martin Kolman
Modified: 2015-04-29 21:39 UTC (History)
7 users (show)

Fixed In Version: libblockdev-0.11-1.fc22
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-04-29 12:57:24 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Martin Kolman 2015-04-08 13:03:44 UTC
Description of problem:
Even though the geolocation lookup is actually done, Anaconda does not use the suggested language value and always defaults to English.

How reproducible:
always

Steps to Reproduce:
1. start a graphical Fedora 22 installation

Actual results:
English is always pre-selected on the Welcome Spoke.

Expected results:
Language is pre-selected based on language suggestion from Geolocation (users in Czech Republic should get Czech pre-selected, etc.).

Additional info:
I have a patch fixing this available.

Comment 1 Fedora Blocker Bugs Application 2015-04-08 13:19:13 UTC
Proposed as a Freeze Exception for 22-beta by Fedora user m4rtink using the blocker tracking app because:

 This means that Anaconda will always start in English, which is a regression to the expected behavior of language being pre-selected based on data from geolocation.

A patch fixing this issue exists and is undergoing review.

Comment 2 Adam Williamson 2015-04-08 14:11:46 UTC
+1 FE for an apparently-safe and tested fix, if we need to rebuild anaconda to fix a blocker or something.

Comment 3 Petr Schindler 2015-04-13 17:29:15 UTC
Discussed at today's blocker review meeting [1].

This bug was accepted as Freeze Exception - this is a highly-visible issue that can't be fixed with an update and inconveniences users who don't read English

[1] http://meetbot.fedoraproject.org/fedora-blocker-review/2015-04-13/

Comment 4 Fedora Update System 2015-04-24 02:15:36 UTC
anaconda-22.20.10-1.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/anaconda-22.20.10-1.fc22

Comment 5 Fedora Update System 2015-04-26 12:47:00 UTC
Package libblockdev-0.11-1.fc22, python-blivet-1.0.8-1.fc22, anaconda-22.20.10-1.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing libblockdev-0.11-1.fc22 python-blivet-1.0.8-1.fc22 anaconda-22.20.10-1.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-6866/libblockdev-0.11-1.fc22,python-blivet-1.0.8-1.fc22,anaconda-22.20.10-1.fc22
then log in and leave karma (feedback).

Comment 6 Fedora Update System 2015-04-29 12:57:24 UTC
libblockdev-0.11-1.fc22, python-blivet-1.0.8-1.fc22, anaconda-22.20.10-1.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 7 DO NOT USE account not monitored (old adamwill) 2015-04-29 21:39:18 UTC
FWIW, verified this in TC1.


Note You need to log in before you can comment on or make changes to this bug.