Bug 1209932 - Packstack installation failed with Neutron-server Could not start Service
Summary: Packstack installation failed with Neutron-server Could not start Service
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: RDO
Classification: Community
Component: openstack-neutron
Version: trunk
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: Kilo
Assignee: Ihar Hrachyshka
QA Contact: Ofer Blaut
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-04-08 13:13 UTC by Eran Kuris
Modified: 2016-04-27 04:49 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-03-30 22:59:35 UTC


Attachments (Terms of Use)
neutron server log (78.19 KB, text/plain)
2015-04-08 13:13 UTC, Eran Kuris
no flags Details
repo files (11.50 KB, application/x-tar)
2015-04-08 13:39 UTC, Eran Kuris
no flags Details
SOSreport (7.78 MB, application/x-xz)
2015-04-08 14:09 UTC, Eran Kuris
no flags Details

Description Eran Kuris 2015-04-08 13:13:17 UTC
Created attachment 1012230 [details]
neutron server  log

Description of problem:
packstack installation fails cause  it Could not start Service[neutron-server]: Execution of '/usr/bin/systemctl start neutron-server' returned 1: Job for neutron-server.service failed 

 
# /usr/bin/systemctl status neutron-server
neutron-server.service - OpenStack Neutron Server
   Loaded: loaded (/usr/lib/systemd/system/neutron-server.service; disabled)
   Active: failed (Result: exit-code) since Wed 2015-04-08 10:29:45 IDT; 11s ago
  Process: 25585 ExecStart=/usr/bin/neutron-server --config-file /usr/share/neutron/neutron-dist.conf --config-file /etc/neutron/neutron.conf --config-file /etc/neutron/plugin.ini --log-file /var/log/neutron/server.log (code=exited, status=1/FAILURE)
 Main PID: 25585 (code=exited, status=1/FAILURE)

Apr 08 10:29:45 puma16.scl.lab.tlv.redhat.com neutron-server[25585]: ERROR: Unable to load neutron from configuration file /usr/share/neutron/api-paste.ini.
Apr 08 10:29:45 puma16.scl.lab.tlv.redhat.com systemd[1]: neutron-server.service: main process exited, code=exited, status=1/FAILURE
Apr 08 10:29:45 puma16.scl.lab.tlv.redhat.com systemd[1]: Failed to start OpenStack Neutron Server.
Apr 08 10:29:45 puma16.scl.lab.tlv.redhat.com systemd[1]: Unit neutron-server.service entered failed state.

Version-Release number of selected component (if applicable):
AllInOne RHEL 7.1 RDO 

How reproducible:

packstack --allinone

Steps to Reproduce:
1.Install RDO AIO ENV : https://www.rdoproject.org/Quickstart

attached all log file  
answer file= http://pastebin.test.redhat.com/274845 

Actual results:

ERROR : Error appeared during Puppet run: 10.35.160.41_neutron.pp
Error: Could not start Service[neutron-server]: Execution of '/usr/bin/systemctl start neutron-server' returned 1: Job for neutron-server.service failed. See 'systemctl status neutron-server.service' and 'journalctl -xn' for details.
You will find full trace in log /var/tmp/packstack/20150408-100315-jKc_BA/manifests/10.35.160.41_neutron.pp.log
Please check log file /var/tmp/packstack/20150408-100315-jKc_BA/openstack-setup.log for more information
Additional information:
 * Time synchronization installation was skipped. Please note that unsynchronized time on server instances might be problem for some OpenStack components.
 * Warning: NetworkManager is active on 10.35.160.41. OpenStack networking currently does not work on systems that have the Network Manager service enabled.
 * File /root/keystonerc_admin has been created on OpenStack client host 10.35.160.41. To use the command line tools you need to source the file.
 * To access the OpenStack Dashboard browse to http://10.35.160.41/dashboard .
Please, find your login credentials stored in the keystonerc_admin in your home directory.
 * To use Nagios, browse to http://10.35.160.41/nagios username: nagiosadmin, password: 1d277484bd7249b4
You have new mail in /var/spool/mail/root

Expected results:


Additional info:

Comment 1 Ihar Hrachyshka 2015-04-08 13:28:47 UTC
ImportError: No module named barbicanclient

Workaround would be to either install python-barbicanclient from PIP or using RDO Kilo repo [1], or to add the following entry in neutron.conf:

[certificates]
cert_manager_class = neutron_lbaas.common.cert_manager.local_cert_manager

Note that there is another bug in lbaas, missing dep. You need to install python-pyasn1-modules to be able to start the service.

[1]: https://repos.fedorapeople.org/repos/openstack/openstack-kilo/

Comment 2 Ihar Hrachyshka 2015-04-08 13:29:33 UTC
Moving the bug to neutron and assigning to myself.

Comment 3 Eran Kuris 2015-04-08 13:39:49 UTC
Created attachment 1012247 [details]
repo files

Comment 4 Ihar Hrachyshka 2015-04-08 13:40:41 UTC
OK, the reason why certificates section is not caught is because we don't pass it as --config-file to neutron-server. We will probably need to introduce another dist config dir, now for neutron-server, since we don't know which configuration files are installed.

Comment 5 Ihar Hrachyshka 2015-04-08 14:06:37 UTC
Fixes to make neutron-server read *aas configuration files are at: https://review.gerrithub.io/#/q/owner:ihrachys%2540redhat.com+status:open

Comment 6 Eran Kuris 2015-04-08 14:09:33 UTC
Created attachment 1012257 [details]
SOSreport

Comment 7 Ihar Hrachyshka 2015-04-10 12:37:28 UTC
Should be fixed now, please check with latest delorean builds.


Note You need to log in before you can comment on or make changes to this bug.