Bug 1209951 - [abrt] dnf: migrate.py:185:migrate_history_transction:IntegrityError: NOT NULL constraint failed: trans_end.timestamp
Summary: [abrt] dnf: migrate.py:185:migrate_history_transction:IntegrityError: NOT NUL...
Keywords:
Status: CLOSED DUPLICATE of bug 1209043
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf-plugins-extras
Version: 22
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Packaging Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:30375cedba03857ee61ee0babdf...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-04-08 13:53 UTC by Török Edwin
Modified: 2015-04-09 12:51 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-04-09 12:51:54 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (3.93 KB, text/plain)
2015-04-08 13:53 UTC, Török Edwin
no flags Details
File: dso_list (84 bytes, text/plain)
2015-04-08 13:53 UTC, Török Edwin
no flags Details
File: environ (1.79 KB, text/plain)
2015-04-08 13:53 UTC, Török Edwin
no flags Details

Description Török Edwin 2015-04-08 13:53:17 UTC
Description of problem:
$ sudo dnf migrate
Waiting for process with pid 16659 to finish.
Using metadata from Wed Apr  8 16:50:07 2015 (0:00:59 hours old)
Migrating history data...
Traceback (most recent call last):
  File "/bin/dnf", line 36, in <module>
    main.user_main(sys.argv[1:], exit_code=True)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 185, in user_main
    errcode = main(args)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 84, in main
    return _main(base, args)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 134, in _main
    cli.run()
  File "/usr/lib/python2.7/site-packages/dnf/cli/cli.py", line 1071, in run
    return self.command.run(self.base.extcmds)
  File "/usr/lib/python2.7/site-packages/dnf-plugins/migrate.py", line 117, in run
    self.migrate_history()
  File "/usr/lib/python2.7/site-packages/dnf-plugins/migrate.py", line 134, in migrate_history
    self.migrate_history_transction(yum_history, dnf_history)
  File "/usr/lib/python2.7/site-packages/dnf-plugins/migrate.py", line 185, in migrate_history_transction
    t.return_code))
sqlite3.IntegrityError: NOT NULL constraint failed: trans_end.timestamp

Version-Release number of selected component:
dnf-0.6.5-1.fc22

Additional info:
reporter:       libreport-2.5.0
cmdline:        /usr/bin/python -OO /bin/dnf migrate
executable:     /bin/dnf
kernel:         4.0.0-0.rc5.git1.3.fc22.x86_64
runlevel:       N 5
type:           Python
uid:            0

Truncated backtrace:
migrate.py:185:migrate_history_transction:IntegrityError: NOT NULL constraint failed: trans_end.timestamp

Traceback (most recent call last):
  File "/bin/dnf", line 36, in <module>
    main.user_main(sys.argv[1:], exit_code=True)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 185, in user_main
    errcode = main(args)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 84, in main
    return _main(base, args)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 134, in _main
    cli.run()
  File "/usr/lib/python2.7/site-packages/dnf/cli/cli.py", line 1071, in run
    return self.command.run(self.base.extcmds)
  File "/usr/lib/python2.7/site-packages/dnf-plugins/migrate.py", line 117, in run
    self.migrate_history()
  File "/usr/lib/python2.7/site-packages/dnf-plugins/migrate.py", line 134, in migrate_history
    self.migrate_history_transction(yum_history, dnf_history)
  File "/usr/lib/python2.7/site-packages/dnf-plugins/migrate.py", line 185, in migrate_history_transction
    t.return_code))
IntegrityError: NOT NULL constraint failed: trans_end.timestamp

Local variables in innermost frame:
dnf_tid: 61
pid: 1710
yum_trans_list: [<dnf.yum.history.YumHistoryTransaction object at 0x7f19a5c00f90>, <dnf.yum.history.YumHistoryTransaction object at 0x7f19a5c00fd0>, <dnf.yum.history.YumHistoryTransaction object at 0x7f19a5c00e90>, <dnf.yum.history.YumHistoryTransaction object at 0x7f19a5c00b10>, <dnf.yum.history.YumHistoryTransaction object at 0x7f19a5c00b50>, <dnf.yum.history.YumHistoryTransaction object at 0x7f19a59bf250>, <dnf.yum.history.YumHistoryTransaction object at 0x7f19a59bf290>, <dnf.yum.history.YumHistoryTransaction object at 0x7f19a59bf2d0>, <dnf.yum.history.YumHistoryTransaction object at 0x7f19a59bf310>, <dnf.yum.history.YumHistoryTransaction object at 0x7f19a59bf350>, <dnf.yum.history.YumHistoryTransaction object at 0x7f19a59bf390>, <dnf.yum.history.YumHistoryTransaction object at 0x7f19a59bf3d0>, <dnf.yum.history.YumHistoryTransaction object at 0x7f19a59bf410>, <dnf.yum.history.YumHistoryTransaction object at 0x7f19a59bf450>, <dnf.yum.history.YumHistoryTransaction object at 0x7f19a59bf490>, <dnf.yum.history.YumHistoryTransaction object at 0x7f19a59bf4d0>, <dnf.yum.history.YumHistoryTransaction object at 0x7f19a59bf510>, <dnf.yum.history.YumHistoryTransaction object at 0x7f19a59bf550>, <dnf.yum.history.YumHistoryTransaction object at 0x7f19a59bf590>, <dnf.yum.history.YumHistoryTransaction object at 0x7f19a59bf5d0>, <dnf.yum.history.YumHistoryTransaction object at 0x7f19a59bf610>, <dnf.yum.history.YumHistoryTransaction object at 0x7f19a59bf650>, <dnf.yum.history.YumHistoryTransaction object at 0x7f19a59bf690>, <dnf.yum.history.YumHistoryTransaction object at 0x7f19a59bf6d0>, <dnf.yum.history.YumHistoryTransaction object at 0x7f19a59bf710>, <dnf.yum.history.YumHistoryTransaction object at 0x7f19a59bf750>, <dnf.yum.history.YumHistoryTransaction object at 0x7f19a59bf790>, <dnf.yum.history.YumHistoryTransaction object at 0x7f19a59bf7d0>, <dnf.yum.history.YumHistoryTransaction object at 0x7f19a59bf810>, <dnf.yum.history.YumHistoryTransaction object at 0x7f19a59bf850>, <dnf.yum.history.YumHistoryTransaction object at 0x7f19a59bf890>, <dnf.yum.history.YumHistoryTransaction object at 0x7f19a59bf8d0>, <dnf.yum.history.YumHistoryTransaction object at 0x7f19a59bf910>, <dnf.yum.history.YumHistoryTransaction object at 0x7f19a59bf950>, <dnf.yum.history.YumHistoryTransaction object at 0x7f19a59bf990>, <dnf.yum.history.YumHistoryTransaction object at 0x7f19a59bf9d0>, <dnf.yum.history.YumHistoryTransaction object at 0x7f19a59bfa10>]
dnf_hist: <dnf.yum.history.YumHistory object at 0x7f19a59bf190>
dnf_cur: <sqlite3.Cursor object at 0x7f19a5bfc1f0>
t: <dnf.yum.history.YumHistoryTransaction object at 0x7f19a59bf9d0>
msg: u'warning: file /etc/lxdm: remove failed: No such file or directory'
yum_hist: <dnf.yum.history.YumHistory object at 0x7f19a7645390>
pkg: <YumHistoryPackageState : xpad-4.1-5.fc22.x86_64 (0x7f19a573d910)>

Comment 1 Török Edwin 2015-04-08 13:53:21 UTC
Created attachment 1012250 [details]
File: backtrace

Comment 2 Török Edwin 2015-04-08 13:53:22 UTC
Created attachment 1012251 [details]
File: dso_list

Comment 3 Török Edwin 2015-04-08 13:53:24 UTC
Created attachment 1012252 [details]
File: environ

Comment 4 Radek Holy 2015-04-09 12:34:18 UTC
Thank you for the report. We'll take a look.

Comment 5 Michael Mráka 2015-04-09 12:51:54 UTC

*** This bug has been marked as a duplicate of bug 1209043 ***


Note You need to log in before you can comment on or make changes to this bug.