Bug 1209957 - iLO2 no longer works under power fencing devices, ipmilan required instead
Summary: iLO2 no longer works under power fencing devices, ipmilan required instead
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 3.4.0
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ovirt-3.6.0-rc
: 3.6.0
Assignee: Eli Mesika
QA Contact: Petr Matyáš
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-04-08 14:05 UTC by Robert McSwain
Modified: 2019-10-10 09:44 UTC (History)
15 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, fence agents accepted boolean agent flags as secure or lanplus (ex: lanplus, lanplus=1, or lanplus=true). The options became unsupported, and caused hosts with those fence agents types to stop functioning. With this update, the fencing options for any existing hosts will have the new format. Any implicitly added options will also have the new format. For existing hosts, the fence agents work as normal after the package is updated. If the options field was defined as an encrypted field, redefine the options field manually to align to the new format. For new hosts, the new format (i.e <key>=<value>) should be defined in the options field.
Clone Of:
Environment:
Last Closed: 2016-03-09 21:02:12 UTC
oVirt Team: Infra
mgoldboi: Triaged+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:0376 normal SHIPPED_LIVE Red Hat Enterprise Virtualization Manager 3.6.0 2016-03-10 01:20:52 UTC
oVirt gerrit 41103 master MERGED core:force bool fence agents options value Never

Description Robert McSwain 2015-04-08 14:05:52 UTC
Description of problem:
When using 'ilo2' on the ilo2 hardware (HP DL380 G6),  I did not use any special (custom) options, and tried it with "secure" checkbox checked as well as unchecked. Using the "lanplus=true, power_wait=4" options work with "ipmilan" but none of those work with ilo2. 

Summary:
ILO2 Hardware
"ilo2" -- does not work in any known combination of settings anymore
"ipmilan" -- works with "lanplus=true, power_wait=4" added


Version-Release number of selected component (if applicable):
RHEV 3.4

How reproducible:
100%

Steps to Reproduce:
1. Upgrade from 3.3 to 3.4 using ilo2 hardware, the ilo2 options no longer work for testing power fencing, but ipmilan works.

Actual results:
Required to use ipmilan as ilo2 fails to work anymore. 

Expected results:
ipmilan and ilo2 work

Comment 1 Eli Mesika 2015-05-13 07:58:34 UTC
First we have to understand why the iLO2 stopped working

please attach 

engine log

vdsm log of the host that was used to perform the fencing action 


It would be great if you could provide those for both 3.3 and 3.4 so we can see what was changed, but if you can't , the logs with failing 3.4 calls will be OK as well

Comment 4 Max Kovgan 2015-06-28 14:13:16 UTC
ovirt-3.6.0-3 release

Comment 15 errata-xmlrpc 2016-03-09 21:02:12 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0376.html


Note You need to log in before you can comment on or make changes to this bug.