Bug 1210003 - "installation destination" gui becomes unresponsive after a cancel on "reclaim space"
Summary: "installation destination" gui becomes unresponsive after a cancel on "reclai...
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 22
Hardware: All
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Vratislav Podzimek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker https://fedoraproject...
Keywords: CommonBugs
: 1224540 (view as bug list)
Depends On:
Blocks: PPCTracker F22FinalBlocker F22PPCBeta
TreeView+ depends on / blocked
 
Reported: 2015-04-08 16:16 UTC by Menanteau Guy
Modified: 2015-06-02 13:16 UTC (History)
14 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2015-04-29 12:57:12 UTC


Attachments (Terms of Use)
/tmp/*log logs (66.55 KB, application/x-gzip)
2015-04-09 08:41 UTC, Jakub Čajka
no flags Details

Description Menanteau Guy 2015-04-08 16:16:33 UTC
I am stuck in "Installation destination" gui after following steps:

1.Start the installer using vnc.
2.Select "I accept my fate".
3.Select "installation destination" gui
4.Select a disk to install (automatic partitioning)
5.Click on "Done"
6.Click on "Reclaim space" in the new triggered gui  
7.Then select "cancel"
At this step, the "reclaim space" gui have been correctly closed but I am
stuck on the "installation destination" gui, allowed to click everywhere in the gui but with no effect when clicking "Done"

I am using a guest ppc64 with command:
qemu-system-ppc64 -enable-kvm -M pseries -cpu POWER7 -smp 2 -m 16G -nographic -nodefaults -monitor stdio -serial pty -device spapr-vscsi -device spapr-vlan,netdev=net10053,mac=xxxxxxxxxxx -netdev bridge,br=br0,id=net10053 -cdrom /home/isos/Fedora-Server-DVD-ppc64-22_Beta_TC2.iso -drive file=/images/f22_ppc64/Beta_TC2/rootfs.qcow2.3.img -drive file=/images/f22_ppc64/Beta_TC2/homefs.qcow2.3.img -drive file=/images/f22_ppc64/Beta_TC2/homexfs.qcow2.3.img -S -boot d

installation image
http://ppc.koji.fedoraproject.org/compose/22_Beta_TC2/22_Beta_TC2/Server/ppc64/iso/Fedora-Server-DVD-ppc64-22_Beta_TC2.iso
with anaconda-22.20.8-1

Comment 1 Jakub Čajka 2015-04-09 08:41:42 UTC
Created attachment 1012579 [details]
/tmp/*log logs

Seems to also affect ppc64le(P8) bare metal. Beta_TC2 image used to reproduce. In attachment are anaconda logs.

Comment 2 Vratislav Podzimek 2015-04-09 09:25:02 UTC
This is not arch-specific, I can reproduce it on x86_64 if I use anaconda-22.20.8-1

Comment 3 Fedora Blocker Bugs Application 2015-04-09 10:26:40 UTC
Proposed as a Blocker for 22-final by Fedora user vpodzime using the blocker tracking app because:

 As explained in the bug, users can get stuck on the disk selection screen if they want to change their mind and hit Cancel in the Reclaim dialog.

Comment 4 Vratislav Podzimek 2015-04-09 10:50:50 UTC
patch sent to anaconda-patches mailing list

Comment 5 Petr Schindler 2015-04-20 16:40:53 UTC
Discussed at today's blocker review meeting [1].

This bug was accepted as Final Blocker - conditional violation of "When using a dedicated installer image, the installer must be able to complete an installation using the text, graphical and VNC installation interfaces.", the condition being you need to cancel out of this screen.

[1] http://meetbot.fedoraproject.org/fedora-blocker-review/2015-04-20/

Comment 6 Fedora Update System 2015-04-24 02:15:29 UTC
anaconda-22.20.10-1.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/anaconda-22.20.10-1.fc22

Comment 7 Fedora Update System 2015-04-26 12:46:53 UTC
Package libblockdev-0.11-1.fc22, python-blivet-1.0.8-1.fc22, anaconda-22.20.10-1.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing libblockdev-0.11-1.fc22 python-blivet-1.0.8-1.fc22 anaconda-22.20.10-1.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-6866/libblockdev-0.11-1.fc22,python-blivet-1.0.8-1.fc22,anaconda-22.20.10-1.fc22
then log in and leave karma (feedback).

Comment 8 Fedora Update System 2015-04-29 12:57:12 UTC
libblockdev-0.11-1.fc22, python-blivet-1.0.8-1.fc22, anaconda-22.20.10-1.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Kamil Páral 2015-05-25 07:41:49 UTC
Verified fixed in F22 RC3.

Comment 10 David Shea 2015-06-02 13:16:32 UTC
*** Bug 1224540 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.