Bug 1210042 - F22 Beta RC1 progress bar does not update
Summary: F22 Beta RC1 progress bar does not update
Status: CLOSED EOL
Alias: None
Product: Fedora
Classification: Fedora
Component: gtk3
Version: 22
Hardware: armhfp
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Matthias Clasen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: RejectedBlocker https://fedoraproject...
Keywords: CommonBugs
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-04-08 18:37 UTC by Dennis Gilmore
Modified: 2016-07-19 13:40 UTC (History)
16 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2016-07-19 13:40:29 UTC


Attachments (Terms of Use)
gtk3-widget-factory on x86_64 (77.09 KB, image/png)
2015-04-14 19:43 UTC, Dennis Gilmore
no flags Details
gtk3-widget-factory on armv7hl (99.99 KB, image/png)
2015-04-14 19:54 UTC, Dennis Gilmore
no flags Details
expected gtk3-demo behavior (423.76 KB, application/octet-stream)
2015-04-15 19:50 UTC, Matthias Clasen
no flags Details
expected gtk3-widget-factory behavior (379.20 KB, application/octet-stream)
2015-04-15 19:59 UTC, Matthias Clasen
no flags Details

Description Dennis Gilmore 2015-04-08 18:37:15 UTC
Description of problem:
Doing a pxe install onto a cubietruck which is a dual core Arm machine with 2GiB of ram. the progress bar never updates. if i switch to the root spoke and back it will update to the status at that point in time and not update again.

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1.pxeboot installer
2.
3.

Actual results:
progress bar does not update

Expected results:
progress bar indicates how far along in the install we are

Additional info:

Comment 1 Paul Whalen 2015-04-08 18:53:58 UTC
The progress works as expected on a Highbank system with 4G ram, however when it finished the "Reboot" button did not appear. When the system was manually rebooted the installation had indeed completed and booted normally.

Comment 2 Adam Williamson 2015-04-08 19:00:15 UTC
Didn't we already have a report for this? It sounds vaguely familiar.

I'm not seeing any criteria it violates, if the install works. My inclination is -1 blocker.

Comment 3 Kevin Fenzi 2015-04-08 20:33:59 UTC
Yeah, -1 beta blocker. We should of course try and fix it before final...

Comment 4 Jaroslav Reznik 2015-04-09 09:17:06 UTC
For the original report - does installation complete? I know it might be tricky to know when it completed but in such case, I think we are ok for Beta. Also as it is confirmed to work on the other ARM machines... -1 blocker for now, we can talk about it later.

Comment 5 Martin Kolman 2015-04-09 09:42:57 UTC
This looks like an architecture specific GUI toolkit issue (screen redraw not working), so reassigning to GTK.

Comment 6 Paul Howarth 2015-04-09 10:22:36 UTC
anaconda-widgets appears to use gtk3 rather than gtk+, so reassigning.

Comment 7 Matthias Clasen 2015-04-09 14:22:46 UTC
I don't have any arm hw to test this. Do you see similar screen redraw issues with other gtk apps after install ?

Comment 8 Adam Williamson 2015-04-10 04:25:59 UTC
Discussed at 2015-04-09 Go/No-Go meeting, acting as a blocker review meeting: https://meetbot.fedoraproject.org/fedora-meeting-2/2015-04-09/f22_beta_gono-go_meeting.2015-04-09-17.00.html . Rejected as a Beta blocker: doesn't prevent the install from running, just makes it a bit harder to see where it's up to. No criterion seems to be violated.

Comment 9 Dennis Gilmore 2015-04-14 18:23:26 UTC
(In reply to Matthias Clasen from comment #7)
> I don't have any arm hw to test this. Do you see similar screen redraw
> issues with other gtk apps after install ?

it is unknown, I installed Fedora Server. so there is no X on the installed system. what would be a good test? I can install and run what is needed to see.

Comment 10 Matthias Clasen 2015-04-14 18:27:15 UTC
gtk3-devel has gtk3-demo, which has a progress bar in the Assistant demo (last step), and gtk3-widget-factory, which has activity-mode progress bars on its first page.

Comment 11 Dennis Gilmore 2015-04-14 19:42:22 UTC
gtk3-demo's progress bar does not update, in gtk3-widget-factory the activity bar bellow 50% updates updates, though I tried to compare what I saw on my x86_64 machine and it was not updating on x86_64, nor was it at all readable. I will attach a screenshot of what I saw

Comment 12 Dennis Gilmore 2015-04-14 19:43:32 UTC
Created attachment 1014453 [details]
gtk3-widget-factory on x86_64

Comment 13 Dennis Gilmore 2015-04-14 19:54:37 UTC
Created attachment 1014469 [details]
gtk3-widget-factory on armv7hl

Comment 14 satellitgo 2015-04-14 21:05:41 UTC
seen with f22 KDE x86_64 RC2 disks-restore USB (dd) to usb HD 
froze installer at "Installing software 64%

Retry with DVD to usb HD  using terminal "liveinst" which worked correctly

Comment 15 Matthias Clasen 2015-04-15 14:53:14 UTC
the arm screenshot looks basically as expected. 

the x86-64 one looks pretty far from it. Whats going on there ? Some custom theme ?

Comment 16 Dennis Gilmore 2015-04-15 15:36:44 UTC
standard theme. I am running kde. I have not tweaked anything. but I guess that is a side distraction that belongs in a different bug. should all the different activity bars update? or just the one? gtk3-demo's progress bar did not update, so it is repeatable.

Comment 17 Matthias Clasen 2015-04-15 19:50:58 UTC
Created attachment 1014929 [details]
expected gtk3-demo behavior

Comment 18 Matthias Clasen 2015-04-15 19:59:48 UTC
Created attachment 1014931 [details]
expected gtk3-widget-factory behavior

Comment 19 satellitgo 2015-05-25 12:17:25 UTC
I see this in a Centrino 2 core MSI Windbox with 2 GB of memory with install of f22-live- KDE RC-3 from DVD. The same DVD in a system 76 i7 laptop with many cores shows progress all the way to completion. I think it may be related to more than 2 GB memory being required for updates to continue.

Smaller DE's seem to complete or go farther in update of XX%

As a test I also see this in a VM
It seems that the xx% progress gets farther, before stopping, in a VM with more memory assigned.

Comment 20 Fedora End Of Life 2016-07-19 13:40:29 UTC
Fedora 22 changed to end-of-life (EOL) status on 2016-07-19. Fedora 22 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.