Bug 12101 - rpm 3.0.4 portability: statfs test fails on OpenBSD
Summary: rpm 3.0.4 portability: statfs test fails on OpenBSD
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm   
(Show other bugs)
Version: 6.2
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-06-11 23:40 UTC by espie
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-09-14 17:58:22 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description espie 2000-06-11 23:40:37 UTC
(this bug report will look strange again, as bugzilla is obviously
slanted against portability bugs)

The statfs check fails abysmally on OpenBSD. Thus transaction.c
does not compile.

On OpenBSD, to get struct statfs, one must
#include <sys/param.h>
#include <sys/mount.h>

-> hence STATSFS_IN_SYS_MOUNT_H is never verified.

sys/mount.h alone is not enough. The configure.in comment is right,
rpm should borrow fileutils test or something better.

Comment 1 Jeff Johnson 2000-06-14 13:20:49 UTC
There's a FreeBSD patch that has been applied since rpm-3.0.4. Will that
also fix this OpenBSD issue?

You're right about fileutils tests.

Comment 2 Jeff Johnson 2000-07-31 15:47:26 UTC
AFAIK, rpm-4.0 will build on *BSD systems.

Stealing the tests from fileutils is still a good idea, that's were many of the
existing tests
were cribbed in the first place. I suspect that the tests should be made
identical.

Comment 3 Jeff Johnson 2001-07-29 15:35:36 UTC
Please reopen with a patch.


Note You need to log in before you can comment on or make changes to this bug.