Bug 1210136 - Should enable support for subtle crypto
Summary: Should enable support for subtle crypto
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: webkitgtk4
Version: rawhide
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Tomas Popela
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: FE-Legal
TreeView+ depends on / blocked
 
Reported: 2015-04-09 02:26 UTC by Michael Catanzaro
Modified: 2015-05-21 13:37 UTC (History)
4 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2015-05-21 13:37:24 UTC


Attachments (Terms of Use)

Description Michael Catanzaro 2015-04-09 02:26:14 UTC
We should build webkitgtk4 with support for subtle crypto [1]. All we need to do is add a BuildRequires for gnutls-devel.

Blocking FE-Legal out of caution. I'm not aware of any problems and I believe our Firefox package already implements the same features, but I've done no research.

[1] https://developer.mozilla.org/en-US/docs/Web/API/SubtleCrypto

Comment 1 Michael Catanzaro 2015-05-21 13:37:24 UTC
After further discussion upstream, we decided to disable subtle crypto by default on all distros, since the feature is not fully complete.


Note You need to log in before you can comment on or make changes to this bug.