Bug 1210166 - [vioscsi] Add multiqueue support to Windows virtio-scsi driver.
Summary: [vioscsi] Add multiqueue support to Windows virtio-scsi driver.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virtio-win
Version: 7.2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Vadim Rozenfeld
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks: 1288337
TreeView+ depends on / blocked
 
Reported: 2015-04-09 05:23 UTC by Vadim Rozenfeld
Modified: 2016-11-04 08:44 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
In addition to supporting single-queue mode, the vioscsi driver is now fully functional in multi-queue mode.
Clone Of:
Environment:
Last Closed: 2016-11-04 08:44:43 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2609 normal SHIPPED_LIVE virtio-win bug fix and enhancement update 2016-11-03 15:27:12 UTC

Description Vadim Rozenfeld 2015-04-09 05:23:31 UTC
Description of problem:
Current implementation of Windows virtio-scsi driver doesn't provide multiqueue support. 

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Specify the number of queues associated with virtio pci device bigger than 1. 
2. Run Windows VM with vioscsi driver installed.
3.

Actual results:
vioscsi driver will crate only one virtio queue to submit requests to the qemu
backend.

Expected results:
vioscsi driver should be able to crate a number of queues to submit concurent requests simultaneously.

Additional info:

Comment 2 Xiaomei Gao 2015-04-22 10:18:51 UTC
Hi Vadim,

How to check multiqueue is enabled in windows guest? We can't get the queues info using DebugView tools after disabling and enabling virtio-scsi driver.

Thanks,
Xiaomei

Comment 3 Vadim Rozenfeld 2015-04-22 23:28:07 UTC
(In reply to Xiaomei Gao from comment #2)
> Hi Vadim,
> 
> How to check multiqueue is enabled in windows guest? We can't get the queues
> info using DebugView tools after disabling and enabling virtio-scsi driver.
> 
> Thanks,
> Xiaomei

Hi Xiaomei,
Unfortunately, there is no way to get such kind of information at the moment.
I can try adding WPP software tracing support if it is absolutely needed.

Best regards,
Vadim.

Comment 8 Xiaomei Gao 2015-04-23 06:15:25 UTC
(In reply to Vadim Rozenfeld from comment #5)
> No problem. Just open a new bug, assigned to me, with request for adding WPP
> tracing facility.

Okay, We have filed Bug 1214568 to track the request.

Thanks,
Xiaomei

Comment 9 lijin 2015-07-17 07:45:01 UTC
change status to verified as qe can run scsi whql job with queues > 1 with virtio-win-prewhql-105

Comment 13 Vadim Rozenfeld 2015-09-30 05:48:35 UTC
Current implementation of vioscsi MQ doesn't show any performance improvement over single queue. Moving this feature to 7.3 for more precise performance analysis and improvement.

Comment 18 lijin 2016-09-02 08:22:47 UTC
change status to verified as qe can pass scsi whql&functional test with queues > 1 with virtio-win-prewhql-124

Comment 20 errata-xmlrpc 2016-11-04 08:44:43 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2609.html


Note You need to log in before you can comment on or make changes to this bug.