Bug 1210205 - nfs-ganesha-gluster Repo not functional
Summary: nfs-ganesha-gluster Repo not functional
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: GlusterFS
Classification: Community
Component: website
Version: 3.7.0
Hardware: All
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-04-09 07:41 UTC by Richard
Modified: 2015-05-18 13:18 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-05-18 13:18:39 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Richard 2015-04-09 07:41:55 UTC
Description of problem: Gluster Yum Repo is missing required metadata.

Version-Release number of selected component (if applicable): 3.4.7

How reproducible: install the latest .repo file from the website and try and install v3.4.7 of gluster.

Steps to Reproduce:
1. cd /etc/yum.repos.d/
2. wget "http://download.gluster.org/pub/gluster/glusterfs/3.4/3.4.7/EPEL.repo/glusterfs-epel.repo"
3. yum search glusterfs

Actual results:

http://download.gluster.org/pub/gluster/glusterfs/3.4/LATEST/EPEL.repo/epel-6Server/x86_64/repodata/repomd.xml: [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 404 Not Found"
Trying other mirror.
http://download.gluster.org/pub/gluster/glusterfs/3.4/LATEST/EPEL.repo/epel-6Server/noarch/repodata/repomd.xml: [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 404 Not Found"

Expected results: yum should find the latest 3.4.7 gluster packages.

Additional info: This is happening quite frequently with releases, please can the root cause be found and fixed.

Comment 1 Justin Clift 2015-04-09 11:39:02 UTC
Oops!

Thanks for letting us know Richard. :)

In theory, this should be fixed now.  Would you be ok to try it out from your end, and verify that just in case?

Comment 2 Richard 2015-04-09 12:39:14 UTC
yes, its working for me now.
Thank you for the prompt fix.
Richard.

Comment 3 Justin Clift 2015-04-09 12:55:10 UTC
Cool. :)

Comment 4 Richard 2015-05-18 08:36:22 UTC
Any idea when the 3.7 repo will be fixed?

http://download.gluster.org/pub/gluster/glusterfs/LATEST/EPEL.repo/

It seems there are issues with this feature of the build process as its always missing something :-(

Comment 5 Justin Clift 2015-05-18 10:09:38 UTC
Well, RPMs for 3.7.0 haven't been released yet for any platform.  They're being worked on presently. ;)

Comment 6 Richard 2015-05-18 11:27:35 UTC
If it's not ready yet, why does the "LATEST" symlink point to a repository that isn't functional?

http://download.gluster.org/pub/gluster/glusterfs/LATEST/

Pehraps next time a release of a new version should be delayed until it is 100% ready to avoid all this confusion.

Comment 7 Justin Clift 2015-05-18 12:03:56 UTC
Good points. :)

Comment 8 Justin Clift 2015-05-18 12:05:40 UTC
Just to ask the question... are you expecting 3.7.0 to be ready for putting directly into a production environment?

If you're intending on using it for a production workload, make sure you test it extensively beforehand.  Or keep using 3.6.x for now. :)

Comment 9 Kaleb KEITHLEY 2015-05-18 12:16:28 UTC
The _release_ is the source tar file.

We provide RPMs and DEBs as a service to the community.

Usually we don't change the LATEST symlinks until the RPMs are ready, but sometimes mistakes are made.

RPMs for Fedora and RHEL clones are there now.

Comment 10 Richard 2015-05-18 12:40:51 UTC
(In reply to Justin Clift from comment #8)
> Just to ask the question... are you expecting 3.7.0 to be ready for putting
> directly into a production environment?
> 
> If you're intending on using it for a production workload, make sure you
> test it extensively beforehand.  Or keep using 3.6.x for now. :)

lmao. 3.6 isn't ready for production use either. I'm still on 3.4.7 as that is the only one that works for me.

I want to test 3.7 in my development environment to see if the bugs with 3.5/3.6 have been resolved. Things such as network compression corrupting data or converting a distributed volume with one brick into a replicated volume with two bricks as the change of volume type on 3.6.x doesn't remount after a reboot.

Kelab: Thank you for publishing the RPM's :-)

Cheers,

Rich

Comment 11 Richard 2015-05-18 12:52:54 UTC
Any chance you could fix this one too:

]$ yum info nfs-ganesha-gluster
Loaded plugins: downloadonly, fastestmirror, local, remove-with-leaves, rpm-warm-cache, security, show-leaves
Loading mirror speeds from cached hostfile
 * epel: epel.check-update.co.uk
 * remi: remi.check-update.co.uk
 * remi-php56: remi.check-update.co.uk
 * sl: ftp2.scientificlinux.org
 * sl-security: ftp2.scientificlinux.org
 * sl6x: ftp2.scientificlinux.org
 * sl6x-fastbugs: ftp2.scientificlinux.org
 * sl6x-security: ftp2.scientificlinux.org
http://download.gluster.org/pub/gluster/glusterfs/nfs-ganesha/EPEL.repo/epel-6.6/x86_64/repodata/repomd.xml: [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 404 Not Found"
Trying other mirror.
http://download.gluster.org/pub/gluster/glusterfs/nfs-ganesha/EPEL.repo/epel-6.6/noarch/repodata/repomd.xml: [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 404 Not Found"
Trying other mirror.
Error: No matching Packages to list


Note You need to log in before you can comment on or make changes to this bug.