Bug 1210259 - missing libicui18n.so.52 after fedup to F22, firefox won't start
Summary: missing libicui18n.so.52 after fedup to F22, firefox won't start
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox
Version: 22
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Martin Stransky
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: RejectedBlocker AcceptedFreezeException
Depends On:
Blocks: F22BetaFreezeException
TreeView+ depends on / blocked
 
Reported: 2015-04-09 09:56 UTC by Lukas Brabec
Modified: 2015-05-06 12:50 UTC (History)
9 users (show)

Fixed In Version: firefox-37.0.1-1.fc22
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-05-06 12:50:34 UTC


Attachments (Terms of Use)
fedup log (819.89 KB, text/plain)
2015-04-09 09:56 UTC, Lukas Brabec
no flags Details

Description Lukas Brabec 2015-04-09 09:56:23 UTC
Created attachment 1012617 [details]
fedup log

Trying to do fedup from F21 to F22 Beta RC1, it gives me this warning at beginning of fedup output:
WARNING: potential problems with upgrade
  firefox-37.0-2.fc21.x86_64 (no replacement) requires libicu-52.1-5.fc21.x86_64 (replaced by libicu-54.1-1.fc22.x86_64)
  perl-Carp-1.36-1.fc21.noarch (no replacement) requires 4:perl-5.18.4-306.fc21.x86_64 (replaced by 4:perl-5.20.2-321.fc22.x86_64)
<...some output omitted...>
WARNING: problems were encountered during transaction test:
  broken dependencies
    perl-Carp-1.36-1.fc21.noarch requires perl-4:5.18.4-306.fc21.x86_64
    firefox-37.0-2.fc21.x86_64 requires libicu-52.1-5.fc21.x86_64
Continue with the upgrade at your own risk.


When fedup is done and F22 is booted, firefox won't start due to broken dep I was warned about.
$ firefox
XPCOMGlueLoad error for file /usr/lib64/firefox/libxul.so:
libicui18n.so.52: cannot open shared object file: No such file or directory
Couldn't load XPCOM.


$ yum-deprecated check
Yum command has been deprecated, use dnf instead.
See 'man dnf' and 'man yum2dnf' for more information.

Loaded plugins: langpacks
firefox-37.0-2.fc21.x86_64 has missing requires of libicudata.so.52()(64bit)
firefox-37.0-2.fc21.x86_64 has missing requires of libicui18n.so.52()(64bit)
firefox-37.0-2.fc21.x86_64 has missing requires of libicuuc.so.52()(64bit)
perl-Carp-1.36-1.fc21.noarch has missing requires of perl(:MODULE_COMPAT_5.18.4)
Error: check all


command
# dnf distro-sync firefox
fixed the problem and firefox started as expected.


Steps to Reproduce:
1. install F21 and upgrade it, install fedup
2. fedup --network 22 --instrepo https://dl.fedoraproject.org/pub/alt/stage/22_Beta_RC1/Server/x86_64/os
3. reboot and complete fedup

Comment 1 Kamil Páral 2015-04-09 10:08:30 UTC
The problem is that F21 contains firefox-37.0.1-1.fc21, but F22 contains firefox-36.0.4-1.fc22. We need to push this to stable:
https://admin.fedoraproject.org/updates/FEDORA-2015-5694/firefox-37.0.1-1.fc22

Proposing as a blocker:
https://fedoraproject.org/wiki/Fedora_22_Beta_Release_Criteria#Upgrade_requirements
 The upgraded system must meet all release criteria. 
https://fedoraproject.org/wiki/Fedora_22_Alpha_Release_Criteria#Required_applications
It must be possible to run the default web browser and a terminal application from all release-blocking desktop environments. 

Please note this does not affect the compose contents, we just need to push that update to stable.

Comment 2 Adam Williamson 2015-04-09 16:15:55 UTC
+1 blocker, makes sense to push this stable asap.

Comment 3 Adam Williamson 2015-04-10 04:24:16 UTC
Discussed at 2015-04-09 Go/No-Go meeting, acting as a blocker review meeting: https://meetbot.fedoraproject.org/fedora-meeting-2/2015-04-09/f22_beta_gono-go_meeting.2015-04-09-17.00.html . Rejected as a blocker - we can push this stable before the Beta release (but after sign-off) without it being marked as a blocker.

However, I'm gonna propose it as an FE, as we're now slipped for another week - we should get it in to help people doing upgrades now.

Comment 4 Kalev Lember 2015-04-13 15:17:15 UTC
+1 FE

Comment 5 Petr Schindler 2015-04-13 17:46:09 UTC
Discussed at today's blocker review meeting [1].

This bug was accepted as Freeze Exception - it would be good to push this stable ASAP to help people testing fedup

[1] http://meetbot.fedoraproject.org/fedora-blocker-review/2015-04-13/

Comment 6 Adam Williamson 2015-04-13 18:37:29 UTC
marking 'ON_QA' as the update is available (helps me not miss it when doing requests)

Comment 7 Rex Dieter 2015-05-06 12:50:34 UTC
https://admin.fedoraproject.org/updates/FEDORA-2015-5694/firefox-37.0.1-1.fc22

went stable awhile back, I believe this bug can be closed now.


Note You need to log in before you can comment on or make changes to this bug.