Bug 1210289 - RFE: Have a way to wait on dnf lock rather than terminate
RFE: Have a way to wait on dnf lock rather than terminate
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
: FutureFeature
: 1245858 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-04-09 06:58 EDT by Bruno Wolff III
Modified: 2015-09-23 00:12 EDT (History)
8 users (show)

See Also:
Fixed In Version: 1.1.1-2.fc23
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-09 19:19:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bruno Wolff III 2015-04-09 06:58:22 EDT
Description of problem:
Currently when dnf holds a lock on its data and a second dnf process gets to the point where it is ready to update data, the second process will exit. It would be more useful for that process to wait until it can get a lock on the data and then proceed (which is what yum does). If this can't be the default, having an option to request that behavior would be nice.
Comment 1 Honza Silhan 2015-07-21 08:28:19 EDT
Michal, you have fixed this, right?
Comment 2 Honza Silhan 2015-08-10 08:42:53 EDT
*** Bug 1245858 has been marked as a duplicate of this bug. ***
Comment 3 Michal Luscon 2015-08-18 09:13:35 EDT
Fixed by https://github.com/rpm-software-management/dnf/pull/335
Comment 4 Fedora Update System 2015-09-01 05:51:44 EDT
dnf-plugins-core-0.1.11-1.fc23 dnf-1.1.1-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-14743
Comment 5 Fedora Update System 2015-09-01 16:22:28 EDT
dnf-1.1.1-1.fc23, dnf-plugins-core-0.1.11-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update dnf dnf-plugins-core'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-14743
Comment 6 Fedora Update System 2015-09-08 08:38:48 EDT
dnf-1.1.1-2.fc22 dnf-plugins-core-0.1.11-1.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-14744
Comment 7 Fedora Update System 2015-09-08 08:38:57 EDT
dnf-1.1.1-2.fc22 dnf-plugins-core-0.1.11-1.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-14744
Comment 8 Fedora Update System 2015-09-08 08:39:51 EDT
dnf-1.1.1-2.fc23 dnf-plugins-core-0.1.11-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-14743
Comment 9 Fedora Update System 2015-09-08 13:51:51 EDT
dnf-1.1.1-2.fc23, dnf-plugins-core-0.1.11-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update dnf dnf-plugins-core'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-14743
Comment 10 Fedora Update System 2015-09-08 17:26:08 EDT
dnf-1.1.1-2.fc22, dnf-plugins-core-0.1.11-1.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update dnf-plugins-core dnf'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-14744
Comment 11 Fedora Update System 2015-09-09 19:18:58 EDT
dnf-1.1.1-2.fc22, dnf-plugins-core-0.1.11-1.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2015-09-23 00:11:50 EDT
dnf-1.1.1-2.fc23, dnf-plugins-core-0.1.11-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.