Bug 1210391 - Error message when searching for Docker image refers to Foreman ticketing system
Summary: Error message when searching for Docker image refers to Foreman ticketing system
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Container Management
Version: 6.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-04-09 15:05 UTC by Og Maciel
Modified: 2019-09-26 13:53 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 08:50:37 UTC
Target Upstream Version:


Attachments (Terms of Use)
Error message displayed in the ui (116.70 KB, image/png)
2015-04-09 15:05 UTC, Og Maciel
no flags Details
error includes 'Satellite ticketing system' instead of foreman (34.21 KB, image/png)
2016-03-21 12:24 UTC, Sachin Ghai
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1500 normal SHIPPED_LIVE Red Hat Satellite 6.2 Base Libraries 2016-07-27 12:24:38 UTC

Description Og Maciel 2015-04-09 15:05:34 UTC
Created attachment 1012719 [details]
Error message displayed in the ui

Description of problem:

When an error happens while using the New Container wizard forms (creating a new Docker container for example), the message that pops up suggests that a bug report should be made using the Foreman ticketing system. Instead we should point the users to use Red Hat's Bugzilla.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. You'll have to cause an error to happen in the New Container wizard to see the error message (see https://bugzilla.redhat.com/show_bug.cgi?id=1209639 for an example)
2.
3.

Actual results:

The error message that is displayed mentions the Foreman ticketing system

Expected results:

Any error message should point users to Red Hat's Bugzilla


Additional info:

Comment 2 Brad Buckingham 2015-09-02 19:25:46 UTC
This should no longer be an issue with Satellite 6.1.1 GA.

RPMs:
  ruby193-rubygem-katello-2.2.0.66-1.el7sat.noarch
  foreman-1.7.2.34-1.el7sat.noarch

The error referenced is generated from the following file:
  /usr/share/foreman/app/views/common/500.html.erb

The above file states:
  <%= _("If you feel this is an error with Satellite 6 itself, please open a new issue with") %> <%= link_to _("Satellite ticketing system"), "https://access.redhat.com/home", :rel => "external" %>,


Going to move to ON_QA for verification.

Comment 3 Sachin Ghai 2016-03-21 12:21:42 UTC
Verified with

Comment 4 Sachin Ghai 2016-03-21 12:23:08 UTC
Verified with Sat6.2 snap4. Now webUI points to Satellite ticketing system in case of any error generated while creating new container. Please see the screenshot for verification

Comment 5 Sachin Ghai 2016-03-21 12:24:32 UTC
Created attachment 1138577 [details]
error includes 'Satellite ticketing system' instead of foreman

Comment 8 errata-xmlrpc 2016-07-27 08:50:37 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500


Note You need to log in before you can comment on or make changes to this bug.