Bug 1210479 - Sample deploy-baremetal-overcloudrc should be commented
Summary: Sample deploy-baremetal-overcloudrc should be commented
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: instack
Version: 7.0 (Kilo)
Hardware: Unspecified
OS: Unspecified
high
unspecified
Target Milestone: ga
: Director
Assignee: Dan Sneddon
QA Contact: Omri Hochman
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-04-09 20:03 UTC by Dan Sneddon
Modified: 2015-08-05 13:51 UTC (History)
7 users (show)

Fixed In Version: instack-undercloud-2.1.2-11.el7ost
Doc Type: Deprecated Functionality
Doc Text:
The deploy-baremetal-overcloudrc file is no longer used in the deployment process. Deployments now use the "openstack overcloud deploy" command and the associated command line arguments.
Clone Of:
Environment:
Last Closed: 2015-08-05 13:51:09 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Gerrithub.io 236808 None None None Never
Red Hat Product Errata RHEA-2015:1549 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform director Release 2015-08-05 17:49:10 UTC

Description Dan Sneddon 2015-04-09 20:03:41 UTC
Description of problem:
Instack uses a file named deploy-overcloudrc to configure the overcloud. When using the sample deploy-baremetal-overcloudrc it isn't at all clear what the environment variables do. Can we add comments to the sample file to explain what things like "NETWORK_CIDR" represent?

Version-Release number of selected component (if applicable):
instack.noarch                 0.0.6.4-g57c723a.el7.centos
instack-undercloud.noarch      2.0.0-dev1584.g9dbaa26.el7.centos

How reproducible:
100%

Steps to Reproduce:
1. Install instack-undercloud
2. Try to set up deploy-overcloudrc
3. Get confused, ask for help, find that nobody on IRC seems to know what NETWORK_CIDR is either.

Actual results:
No documentation in sample file

Expected results:
Environment variables should have descriptive text, like instack.answers has.

Additional info:

Comment 1 Dan Sneddon 2015-04-09 20:14:56 UTC
I'm working on a patch to address this...

Comment 5 chris alfonso 2015-06-15 19:31:57 UTC
Dan, was this patch pulled in?

Comment 6 Dan Sneddon 2015-06-25 21:32:25 UTC
(In reply to chris alfonso from comment #5)
> Dan, was this patch pulled in?

No, the patch is here: https://review.gerrithub.io/#/c/236808/

Comment 8 Omri Hochman 2015-07-09 18:46:11 UTC
Verified  :
instack-0.0.7-1.el7ost.noarch
instack-undercloud-2.1.2-11.el7ost.noarch

We switched to use unified-cli command for overcloud deployed, 
Comments over the --arguments should be covered in the --help of the uni-cli and track in this BZ : 

https://bugzilla.redhat.com/show_bug.cgi?id=1241668

Comment 10 errata-xmlrpc 2015-08-05 13:51:09 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2015:1549


Note You need to log in before you can comment on or make changes to this bug.