Bug 1210483 - Cannot join Active Directory realm with realmd on Fedora 22 Server Beta RC1
Summary: Cannot join Active Directory realm with realmd on Fedora 22 Server Beta RC1
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: realmd
Version: 22
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Stef Walter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker
Depends On:
Blocks: F22BetaBlocker
TreeView+ depends on / blocked
 
Reported: 2015-04-09 20:27 UTC by Stephen Gallagher
Modified: 2015-04-22 22:55 UTC (History)
8 users (show)

Fixed In Version: realmd-0.16.0-1.fc22
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-04-17 02:29:14 UTC


Attachments (Terms of Use)

Description Stephen Gallagher 2015-04-09 20:27:18 UTC
Description of problem:
Attempting to use Cockpit to join an Active Directory domain fails with the error:

! Failed to enroll machine in realm: Failed to execute child process "/usr/bin/net" (No such file or directory)

The root of this is that the samba package moved the /usr/bin/net package from samba-common to the samba-common-tools subpackage. realmd needs to be updated to install the correct package.

Version-Release number of selected component (if applicable):
realmd-0.15.2-1.fc22

How reproducible:
Every time

Steps to Reproduce:
1. Install Fedora 22 Server Beta RC1
2. Accept all anaconda defaults
3. Log into the Cockpit web UI
4. Attempt to join an Active Directory domain from the "System" tab. (Using correct credentials). See https://fedoraproject.org/wiki/QA:Testcase_realmd_join_sssd

Actual results:
! Failed to enroll machine in realm: Failed to execute child process "/usr/bin/net" (No such file or directory)

Expected results:
Successful domain join

Additional info:

Comment 1 Fedora Blocker Bugs Application 2015-04-09 20:28:30 UTC
Proposed as a Blocker for 22-beta by Fedora user sgallagh using the blocker tracking app because:

 Alpha criterion: "It must be possible to join the system to a FreeIPA or Active Directory domain at install time and post-install, and the system must respect the identity, authentication and access control configuration provided by the domain."

Comment 2 Stephen Gallagher 2015-04-09 21:00:30 UTC
There are two ways to fix this bug:
1) Adjust comps.xml to include samba-common-tools as part of the @domain-client group
2) Fix realmd to install the correct package on-demand.

I'm going to do both, since we want realmd to behave properly in the general case, but on Fedora Server it makes sense to have that package preinstalled as well.

Comment 3 Fedora Update System 2015-04-09 21:04:51 UTC
realmd-0.15.2-2.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/realmd-0.15.2-2.fc22

Comment 4 Mike Ruckman 2015-04-09 21:09:27 UTC
+1 per the cited criteria

Comment 5 Jaroslav Reznik 2015-04-10 08:32:27 UTC
To speed up blocker process, +1 blocker.

Comment 6 Adam Williamson 2015-04-10 17:38:33 UTC
+1 blocker, that's +3/4 (inc. Stephen), so setting accepted.

Comment 7 Fedora Update System 2015-04-10 18:22:04 UTC
Package realmd-0.15.2-2.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing realmd-0.15.2-2.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-5960/realmd-0.15.2-2.fc22
then log in and leave karma (feedback).

Comment 8 Fedora Update System 2015-04-14 11:24:54 UTC
realmd-0.16.0-1.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/realmd-0.16.0-1.fc22

Comment 9 Fedora Update System 2015-04-17 02:29:14 UTC
realmd-0.15.2-2.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2015-04-22 22:55:29 UTC
realmd-0.16.0-1.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.