Bug 1210521 - Sync MTRRs with KVM and disable on reset
Summary: Sync MTRRs with KVM and disable on reset
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm-rhev
Version: 7.2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Alex Williamson
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On: 1210510
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-04-10 00:18 UTC by Alex Williamson
Modified: 2015-12-04 16:35 UTC (History)
9 users (show)

Fixed In Version: qemu-2.3
Doc Type: Bug Fix
Doc Text:
Clone Of: 1210510
Environment:
Last Closed: 2015-12-04 16:35:49 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:2546 normal SHIPPED_LIVE qemu-kvm-rhev bug fix and enhancement update 2015-12-04 21:11:56 UTC

Comment 3 Chao Yang 2015-09-01 06:35:18 UTC
Verified passed as no regression was found with qemu-kvm-rhev-2.3.0-21.el7.x86_64

Steps:
1. cold plug a vfio-pci device, boot the guest
2. reboot the guest and look for any unusual delays in the VM BIOS init
3. hot-unplug the vfio-pci device and migrate the VM
4. reboot the guest on the migration target
5. hot plug a vfio-pci device to it and reboot
6. hot-unplug the vfio-pci device and migrate the VM back 
7. reboot the guest on the migration target

Tests were done with both seabios(seabios-bin-1.7.5-11.el7.noarch) and OVMF(OVMF-20150414-2.gitc9e5618.el7.noarch.rpm), neither observed abnormal behaviour during firmware initialization. 

CLI:

/usr/libexec/qemu-kvm -S -name test -m 4G -realtime mlock=on -smp 4,sockets=2,cores=2,threads=1 -no-user-config -nodefaults -rtc base=utc,driftfix=slew -global kvm-pit.lost_tick_policy=discard -drive file=/usr/share/OVMF/OVMF_CODE.fd,if=pflash,format=raw,unit=0,readonly=on -drive file=/usr/share/OVMF/OVMF_VARS.fd,if=pflash,format=raw,unit=1 -boot menu=on,strict=on -device ich9-usb-ehci1,id=usb,bus=pci.0,addr=0x5.0x7 -device ich9-usb-uhci1,masterbus=usb.0,firstport=0,bus=pci.0,multifunction=on,addr=0x5 -device ich9-usb-uhci2,masterbus=usb.0,firstport=2,bus=pci.0,addr=0x5.0x1 -device ich9-usb-uhci3,masterbus=usb.0,firstport=4,bus=pci.0,addr=0x5.0x2 -device virtio-scsi-pci,id=scsi0,bus=pci.0 -drive file=/mnt/rhel7.2-with-ovmf.qcow2,if=none,id=drive-virtio-disk0,format=qcow2,cache=none -device virtio-blk-pci,drive=drive-virtio-disk0,id=virtio-disk0,bootindex=1 -device virtio-serial-pci,id=virtio-serial0,bus=pci.0,addr=0x7 -netdev tap,id=idinWyYp,vhost=on -device virtio-net-pci,mac=42:ce:a9:d1:4d:d5,id=idlbq7eA,netdev=idinWyYp -device usb-tablet,id=input0 -vga qxl -global qxl-vga.ram_size=67108864 -global qxl-vga.vram_size=33554432 -spice port=8000,disable-ticketing -msg timestamp=on -monitor stdio -device vfio-pci,host=0000:05:00.0,id=pf



Per above, this issue has fixed.

Comment 4 juzhang 2015-09-07 02:22:52 UTC
According to comment3, set this issue as verified.

Comment 6 errata-xmlrpc 2015-12-04 16:35:49 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2546.html


Note You need to log in before you can comment on or make changes to this bug.