Bug 1210572 - The usage of manual doc and error message about 'sparse' should be consistent in virt-install
Summary: The usage of manual doc and error message about 'sparse' should be consistent...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virt-manager
Version: 7.2
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: rc
: ---
Assignee: Pavel Hrdina
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On: 873582
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-04-10 06:06 UTC by tingting zheng
Modified: 2015-11-19 05:25 UTC (History)
11 users (show)

Fixed In Version: virt-manager-1.2.1-1-el7
Doc Type: Bug Fix
Doc Text:
Clone Of: 873582
Environment:
Last Closed: 2015-11-19 05:25:22 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:2206 0 normal SHIPPED_LIVE virt-manager bug fix and enhancement update 2015-11-19 08:17:29 UTC

Comment 2 Giuseppe Scrivano 2015-04-10 11:28:37 UTC
patch proposed upstream:

https://www.redhat.com/archives/virt-tools-list/2015-April/msg00078.html

Comment 3 Giuseppe Scrivano 2015-04-10 14:44:32 UTC
upstream commit:

commit 549c93be5f2d102f61ba4b7276561bb119b5220c
Author: Giuseppe Scrivano <gscrivan>
Date:   Fri Apr 10 12:37:09 2015 +0200

    doc: make --sparse documentation consistent with error message
    
    Closes: https://bugzilla.redhat.com/show_bug.cgi?id=1210572
    
    Signed-off-by: Giuseppe Scrivano <gscrivan>

Comment 5 fwu 2015-05-29 09:19:49 UTC
I can reproduce this bug with package:
virt-manager-1.1.0-12.el7.noarch

Steps are the same as description above.

Then try to verify with new build:
virt-manager-1.2.0-4.el7.noarch

Steps:
1. Check manual doc of virt-install about sparse, check the usage explanation:
#man virt-install

 sparse
             whether to skip fully allocating newly created storage. Value is
             'yes' or 'no'. Default is 'yes' (do not fully allocate)
             unless it isn't supported by the underlying storage type.

             The initial time taken to fully-allocate the guest virtual disk
             (SPARSE=FALSE) will be usually balanced by faster install times
             inside the guest. Thus use of this option is recommended to
             ensure consistently high performance and to avoid I/O errors in
             the guest should the host filesystem fill up.

2. Use "--nonsparse" with "--disk" at the same time:
#virt-install -n demo2 -r 512 -l http://download.englab.nay.redhat.com/pub/rhel/rel-eng/RHEL-6.7-20150519.0/6.7/Server/x86_64/os/ --disk path=/var/lib/libvirt/images/demo2.img,size=5 --nonsparse
Check the error message.

"ERROR    Cannot mix --file, --nonsparse, or --file-size with --disk options. Use --disk PATH[,size=SIZE][,sparse=yes|no]"

3. Compare the usage of manual doc and error message about 'sparse'.

Result:
On paragraph 2 of the listed manual doc, '(sparse=false)' still exist and it is not consistent with error message and the rest of manual doc listed above.

According to the result above, move this bug from ON_QA to ASSIGNED.

Comment 6 Pavel Hrdina 2015-06-19 14:15:07 UTC
Upstream patch proposed:

https://www.redhat.com/archives/virt-tools-list/2015-June/msg00203.html

Comment 7 Pavel Hrdina 2015-06-22 13:01:51 UTC
Upstream commit:

commit 3a3a1d5bd455c600ba3f3b1cd172df10bfeb72de
Author: Pavel Hrdina <phrdina>
Date:   Fri Jun 19 16:14:28 2015 +0200

    doc: make --sparse documentation in man page consistent
    
    Commit 549c93be fixed a man page to make --sparse documentation
    consistent, but it forget to updated also the next paragraph.
    
    Resolves: https://bugzilla.redhat.com/show_bug.cgi?id=1210572
    
    Signed-off-by: Pavel Hrdina <phrdina>

Comment 10 fwu 2015-06-24 07:40:12 UTC
Verify this bug with new build:
virt-manager-1.2.1-2.el7.noarch

Steps:
1. Check manual doc of virt-install about sparse, check the usage explanation:
#man virt-install

 sparse
             whether to skip fully allocating newly created storage. Value is
             'yes' or 'no'. Default is 'yes' (do not fully allocate)
             unless it isn't supported by the underlying storage type.

             The initial time taken to fully-allocate the guest virtual disk
             (SPARSE=no) will be usually balanced by faster install times
             inside the guest. Thus use of this option is recommended to
             ensure consistently high performance and to avoid I/O errors in
             the guest should the host filesystem fill up.

2. Use "--nonsparse" with "--disk" at the same time:
#virt-install -n demo2 -r 512 -l http://download.englab.nay.redhat.com/pub/rhel/rel-eng/RHEL-6.7-20150519.0/6.7/Server/x86_64/os/ --disk path=/var/lib/libvirt/images/demo2.img,size=5 --nonsparse
Check the error message.

"ERROR    Cannot mix --file, --nonsparse, or --file-size with --disk options. Use --disk PATH[,size=SIZE][,sparse=yes|no]"

3. Compare the usage of manual doc and error message about 'sparse'.

Result:
It is consistent between error message and the part of manual doc listed above.

According to the result above, move this bug from ON_QA to VERIFIED.

Comment 12 errata-xmlrpc 2015-11-19 05:25:22 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2206.html


Note You need to log in before you can comment on or make changes to this bug.