Bug 1210633 - [RHEVM3.5] import vm fails. Error while executing action: Cannot import VM. Invalid time zone for given OS type.
Summary: [RHEVM3.5] import vm fails. Error while executing action: Cannot import VM. I...
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 3.5.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ovirt-3.6.0-rc
: 3.6.0
Assignee: Martin Betak
QA Contact: Ilanit Stein
URL:
Whiteboard:
Keywords: ZStream
Depends On:
Blocks: 1218669
TreeView+ depends on / blocked
 
Reported: 2015-04-10 08:55 UTC by Ulhas Surse
Modified: 2019-07-16 11:58 UTC (History)
10 users (show)

(edit)
Previously, the timezone Africa/Algiers was not recognized by Red Hat Enterprise Virtualization Manager 3.5. As a result, when importing virtual machines from previous versions that used the timezone failed. This update adds Africa/Algiers to the list of supported timezones. Virtual machines that used the timezone now imports correctly.
Clone Of:
: 1218669 (view as bug list)
(edit)
Last Closed: 2016-03-09 21:02:18 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:0376 normal SHIPPED_LIVE Red Hat Enterprise Virtualization Manager 3.6.0 2016-03-10 01:20:52 UTC
oVirt gerrit 39853 master MERGED core: Add Africa/Algiers Time Zone Never
oVirt gerrit 39887 ovirt-engine-3.5 MERGED core: Add Africa/Algiers Time Zone Never
oVirt gerrit 40384 ovirt-engine-3.5.3 MERGED core: Add Africa/Algiers Time Zone Never

Description Ulhas Surse 2015-04-10 08:55:20 UTC
Description of problem:

Importing RHEL guest from RHEVM3.1 to 3.5 giving following message: 
   Error while executing action: Cannot import VM. Invalid time zone for given OS type.


ANALYSIS

  1) Operating System in admin portal guest settings = "Red Hat Enterprise Linux 6.x x64"
  2) /etc/redhat-release on guest = "Red Hat Enterprise Linux Server release 6.3 (Santiago)"
  3) date on guest = "Wed Apr  8 09:59:34 CEST 2015"
  4) 3.1 database shows: 
     cc4d5383-4bba-4f25-8a2a-5ff8c8f4fb44 | <vm_name>         | Africa/Algiers
 

rehvm engine logs: 

2015-03-26 13:36:54,293 WARN  [org.ovirt.engine.core.bll.ImportVmCommand] (ajp-/127.0.0.1:8702-15) [7aefc4d2] CanDoAction of action ImportVm failed. Reasons:VAR__ACTION__IMPORT,VAR__TYPE__VM,ACTION_TYPE_FAILED_INVALID_TIMEZONE
2015-03-26 14:03:36,090 WARN  [org.ovirt.engine.core.bll.ImportVmCommand] (ajp-/127.0.0.1:8702-14) [3a86c3a6] CanDoAction of action ImportVm failed. Reasons:VAR__ACTION__IMPORT,VAR__TYPE__VM,ACTION_TYPE_FAILED_INVALID_TIMEZONE
2015-03-30 13:25:53,174 WARN  [org.ovirt.engine.core.bll.ImportVmCommand] (ajp-/127.0.0.1:8702-3) [53e92e0f] CanDoAction of action ImportVm failed. Reasons:VAR__ACTION__IMPORT,VAR__TYPE__VM,ACTION_TYPE_FAILED_INVALID_TIMEZONE
2015-03-30 13:26:40,777 WARN  [org.ovirt.engine.core.bll.ImportVmCommand] (ajp-/127.0.0.1:8702-9) [2d73982b] CanDoAction of action ImportVm failed. Reasons:VAR__ACTION__IMPORT,VAR__TYPE__VM,ACTION_TYPE_FAILED_INVALID_TIMEZONE

host logs:

</Description><Domain></Domain><CreationDate>2014/09/23 09:32:24</CreationDate><ExportDate>2015/04/09 09:10:37</ExportDate><IsInitilized>true</IsInitilized><IsAutoSuspend>false</IsAutoSuspend><TimeZone>Africa/Algiers</TimeZone><IsStateless>false</IsStateless><Origin>0</Origin><default_boot_sequence>0</default_boot_sequence><quota_id>00000000-0000-0000-0000-000000000000</quota_id><VmType>1</VmType><DefaultDisplayType>1</DefaultDisplayType>

Version-Release number of selected component (if applicable):
rhevm-3.5.0-0.32.el6ev.noarch

vdsm-4.9.6-44.3.el6_3.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Export VM from rhevm3.1 environment 
2. Try to inport in rhevm 3.5
3.

Actual results:
 Error while executing action: Cannot import VM. Invalid time zone for given OS type.

Expected results:
 Should be imported 

Additional info:

Comment 3 Martin Betak 2015-04-14 11:48:51 UTC
From quick look at our TimeZone whitelist it seems Africa/Algiers is missing. In 3.1 the timezones were drawn from standard java timezones, but somewhere around the time of Cloud Init implementation we moved to hand-maintained list of timezones. It should be a very simple fix to add Africa/Algiers to this list.

Comment 4 Martin Betak 2015-04-28 15:59:43 UTC
merged to u/s ovirt-engine-3.5 branch

Comment 6 Ilanit Stein 2015-10-11 12:02:03 UTC
Verified on rhevm 3.6.0-15

Verification steps:
==================

1. Create a VM with OS rhel 6.x, and time zone = Algeria standard time,
on rhevm 3.6

2. Exported the VM to export domain.

3. Imported the VM on a rhevm 3.6, using a different VM name => Imported & run successfully.

Comment 8 errata-xmlrpc 2016-03-09 21:02:18 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0376.html


Note You need to log in before you can comment on or make changes to this bug.