Bug 1210639 - pcsc-lite-ccid should be required by qesteidutil
Summary: pcsc-lite-ccid should be required by qesteidutil
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: qesteidutil
Version: 21
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Mihkel Vain
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-04-10 09:09 UTC by Fred New
Modified: 2015-04-22 22:57 UTC (History)
5 users (show)

Fixed In Version: firefox-esteidpkcs11loader-3.8.0.1052-5.fc21
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-04-21 19:17:04 UTC
Type: Bug


Attachments (Terms of Use)

Description Fred New 2015-04-10 09:09:07 UTC
Description of problem:
If I install qesteidutil without pcsc-lite-ccid, the qesteidutil is unable to detect any smart card readers. After I install pcsc-lite-ccid, the utility works as expected. The qesteidutil package should require pcsc-lite-ccid. The same is probably also true for other packages that use smart card readers, like perhaps firefox-esteidpkcs11loader.

Version-Release number of selected component (if applicable):
estonianidcard-3.8.1-2.fc21.noarch
qesteidutil-3.8.0.1106-7.fc21.x86_64

How reproducible:
Always

Steps to Reproduce:
1. On a new system, install estonianidcard.
2. Attempt to use the qesteidutil that just got installed.

Actual results:
The utility displays "No readers found".

Expected results:
The utility should show "No cards found" or information about the card that is in the smart card reader.

Additional info:
The "Expected results" can be attained by installing pcsc-lite-ccid.

Comment 1 Fedora Update System 2015-04-10 18:51:34 UTC
firefox-esteidpkcs11loader-3.8.0.1052-5.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/firefox-esteidpkcs11loader-3.8.0.1052-5.fc22

Comment 2 Fedora Update System 2015-04-10 18:56:45 UTC
firefox-esteidpkcs11loader-3.8.0.1052-5.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/firefox-esteidpkcs11loader-3.8.0.1052-5.fc21

Comment 3 Fedora Update System 2015-04-10 19:01:57 UTC
qesteidutil-3.10.1-2.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/qesteidutil-3.10.1-2.fc22

Comment 4 Fedora Update System 2015-04-10 19:04:16 UTC
firefox-esteidpkcs11loader-3.8.0.1052-5.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/firefox-esteidpkcs11loader-3.8.0.1052-5.fc20

Comment 5 Fedora Update System 2015-04-10 19:13:54 UTC
qesteidutil-3.10.1-2.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/qesteidutil-3.10.1-2.fc21

Comment 6 Fedora Update System 2015-04-10 19:25:17 UTC
qesteidutil-3.10.1-2.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/qesteidutil-3.10.1-2.fc20

Comment 7 Fedora Update System 2015-04-12 02:07:26 UTC
Package firefox-esteidpkcs11loader-3.8.0.1052-5.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing firefox-esteidpkcs11loader-3.8.0.1052-5.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-6029/firefox-esteidpkcs11loader-3.8.0.1052-5.fc22
then log in and leave karma (feedback).

Comment 8 lnie 2015-04-14 05:34:30 UTC
qesteidutil-3.10.1-2.fc22  works

Comment 9 Fred New 2015-04-15 19:03:50 UTC
Limited testing shows that both packages are working as expected. (Sorry for the delay; I've been working on my US taxes.):

I removed pcsc-lite-ccid and confirmed that updating qesteidutil and firefox-esteidpkcs11loader from updates-testing pulled pcsc-lite-ccid back in. I didn't try to update qesteidutil or firefox-esteidpkcs11loader separately.

I then confirmed that qesteidutil loads information from my ID card and will download my picture. I didn't test changing either of my PINs.

And I am able to log into my bank accounts using Firefox. PIN2 not tested.

It looks like I'm a little late for adding positive karma.

Comment 10 Fedora Update System 2015-04-21 19:17:04 UTC
firefox-esteidpkcs11loader-3.8.0.1052-5.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2015-04-21 19:24:14 UTC
qesteidutil-3.10.1-2.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2015-04-22 22:41:59 UTC
firefox-esteidpkcs11loader-3.8.0.1052-5.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 13 Fedora Update System 2015-04-22 22:57:52 UTC
firefox-esteidpkcs11loader-3.8.0.1052-5.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.