Bug 121064 - NVS280 text mode install and X will not start
NVS280 text mode install and X will not start
Status: CLOSED RAWHIDE
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: anaconda (Show other bugs)
3.0
ia32e Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-16 13:18 EDT by Kim Jensen
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-19 16:20:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kim Jensen 2004-04-16 13:18:55 EDT
Description of problem:
When installing RHEL3U2B WS x86_64 on a ia32e box, the install is in 
text mode and once the install completes, X will not start because 
there is no XF86Config file.

On the flip side - when installing RHEL3U2B WS IA32 on the same HW, 
the install is graphical and X starts fine.

The graphics is PCI NVIdia NVS280

Version-Release number of selected component (if applicable):
kernel-2.4.21-12
anaconda-9.1.2-0.RHEL.20040330155035
XFree-4.3.0-62

How reproducible:
Everytime


Steps to Reproduce:
1a. Install RHEL3U2 Beta WS x86-64 w/ NVS280 on ia32e - it's always 
in text mode.
1b. X fails with 
Fatal server error:
no screens found

2a. Install RHEL3U2 Beta WS ia32 2/ NVS280 on x86_64 - it's always 
graphical.
2b. X succeeds 
  
Actual results:
NVS280 installs textually and X fails to start

Expected results:
NVS280 installs graphically and X starts

Additional info:

RHEL3U2Beta WS - IA32 and x86_64 behaved differently
Comment 1 Jeremy Katz 2004-04-16 14:00:26 EDT
Is there a comment about no video hardware found, assuming headless?
Comment 2 Kim Jensen 2004-04-19 15:41:23 EDT
Yes!
   No video hardware found, assuming headless?
   DISPLAY varaible not set.  Starting up text mode!
Comment 3 Jeremy Katz 2004-04-19 16:20:54 EDT
Okay, I have this fixed for the final U2 release then.
Comment 4 Kim Jensen 2004-05-12 12:08:36 EDT
Confirmed - it's fixed.  Thanks!

Note You need to log in before you can comment on or make changes to this bug.