Bug 121069 - kudzu did not update /etc/modprobe.conf, did not detect new sound adapter
kudzu did not update /etc/modprobe.conf, did not detect new sound adapter
Status: CLOSED DEFERRED
Product: Fedora
Classification: Fedora
Component: kudzu (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-16 15:59 EDT by Gene Czarcinski
Modified: 2014-03-16 22:44 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-23 17:04:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gene Czarcinski 2004-04-16 15:59:50 EDT
Description of problem:

I am reported this on the x86_64 platform because that is where I had
the problems.  However, this may apply to all platforms.

kudzu=1.1.54-1
policy=1.11.2-8
systems-config-soundcard=1.2.8-1
kernel=2.6.5-1.322

I got tired of fight the onboard VIA8233 sound adapter on the ASUS
SK8V mobo.  So I disabled the VIA8233 in the BIOS and plugged in an
Ensonic Model 5880 AudioPCI adapter (supported by the snd-ens1371 driver).

When I first booted up after making the change, kudzu detected the
change but did not update /etc/modprobe.com.  Furthermore, it did not
detect the new sound adapter and update /etc/modprobe.conf with its stuff.

OK, manuall edit /etc/modprobe.conf to comment out the via82xx stuff
and rebot to try again.  kudzu now detected no change.  Running
system-config-soundcard recognized the adapter but did not work ...
nothing in /etc/modprobe.conf was changed.

OK, using the old (commented out) stuff for the via82xx as a
"pattern", I created new stuff for the ens1371 (just replaced the names).

Reboot and do lsmod (yes, they are loaded).  Run
system-config-soundcard:  success, I get sound!
Comment 1 Bill Nottingham 2005-09-23 17:04:32 EDT
Closing bugs on older, no longer supported releases. Apologies for any lack of
response.

Please attempt to reproduce this bug on a currently supported release, such as
Fedora Core 4. If it persists, please open a new bug in bugzilla.

Note You need to log in before you can comment on or make changes to this bug.