Bug 121076 - raidstop /dev/md0 or mdadm --stop /dev/md0 fails on 2.4.21-12EL ia64
Summary: raidstop /dev/md0 or mdadm --stop /dev/md0 fails on 2.4.21-12EL ia64
Status: CLOSED DUPLICATE of bug 119532
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: mdadm (Show other bugs)
(Show other bugs)
Version: 3.0
Hardware: ia64 Linux
medium
medium
Target Milestone: ---
Assignee: Doug Ledford
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-04-16 21:04 UTC by Paul Clements
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:02:37 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Paul Clements 2004-04-16 21:04:45 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031030

Description of problem:
RHEL3 Update 2 Beta ia64 

# cat /etc/redhat-release 
Red Hat Enterprise Linux AS release 3 (Taroon Update 2)

/dev/md0 cannot be stopped with raidstop or mdadm --stop (although
other md devices can be stopped), the kernel gives -EBUSY every time
an attempt is made to stop /dev/md0





Version-Release number of selected component (if applicable):
kernel-2.4.21-12.EL, raidtools-1.00.3-7, mdadm-1.5.0-3

How reproducible:
Always

Steps to Reproduce:
# mdadm -C -l 1 -n 2 /dev/md0 /dev/loop1 /dev/loop2

# mdadm --stop /dev/md0
mdadm: fail to stop array /dev/md0: Device or resource busy

# raidstop /dev/md0
/dev/md0: Device or resource busy

(The same sequence works if the device is /dev/md1 or /dev/md2).

Additional info:

Comment 1 Paul Clements 2004-04-19 16:26:15 UTC
The problem is due to the "mdadm --monitor --scan" process that is
started at boot time (/etc/init.d/mdmonitor). If this is stopped,
/dev/md0 can then be stopped.

Comment 2 Doug Ledford 2004-04-22 22:37:30 UTC

*** This bug has been marked as a duplicate of 119532 ***

Comment 3 Red Hat Bugzilla 2006-02-21 19:02:37 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.