Bug 1210833 - pcs is not fully distributed (contains local-only set/query operations)
Summary: pcs is not fully distributed (contains local-only set/query operations)
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: pcs
Version: 7.2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Tomas Jelinek
QA Contact: cluster-qe@redhat.com
URL:
Whiteboard:
: 1217166 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-04-10 16:31 UTC by Jan Pokorný [poki]
Modified: 2020-12-15 07:34 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-12-15 07:34:01 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1176018 0 urgent CLOSED pcs/pcsd should be able to configure pacemaker remote 2021-02-22 00:41:40 UTC

Internal Links: 1176018

Description Jan Pokorný [poki] 2015-04-10 16:31:24 UTC
IMHO it would be appropriate to "distributify", at least by the mean
of specifying remote node (and provided that authentication is set up)
as opposed to local-only, all set/query operations provided.
IIRC, with ccs, you could always specify node(s) you want to work with
-- such modus operandi is simply missing in pcs in some cases.

"pcs resources list" is an example of the operation violating such
expectation.  This is strange as pcs can be run on a dedicated machine
outside of cluster and hence resource-agents package is likely not
installed then.

[For this operation specifically, it would even make sense to be
 sensitive about number of nodes to query
 - single one: standard output as usual
 - more: redacted output stating which resources are common, and then
        per-node extras]

There may be more local-only operations to look at.

Comment 1 Jan Pokorný [poki] 2015-04-15 12:34:25 UTC
This bug was originally triggered by discovery that pcs does not depend
on pacemaker{,-cli} in RHEL 6:

# rpm -qR pcs | grep -e pacemaker -e pc | echo Nothing
> Nothing
# rpm -q pcs
> pcs-0.9.139-5.el6.x86_64

Hence I was expecting that this is another form of saying "install pcs
whenever you want, manage arbitrary cluster with that incl. just the
external ones (i.e., the machine running pcs doesn't need to have
anything in common with clusters modulo pcs itself
[no pacemaker CLI tools need to be installed, etc.])".

Comment 2 Jan Pokorný [poki] 2015-04-15 13:14:33 UTC
re [comment 1]:
Apparently: s/whenever/wherever

Comment 3 Tomas Jelinek 2015-11-20 15:42:16 UTC
*** Bug 1217166 has been marked as a duplicate of this bug. ***

Comment 5 Jan Pokorný [poki] 2016-03-07 15:08:44 UTC
A very specific use-case (commands run on virt-002):

# crm_attribute -t nodes -N virt-002 -n maintenance -v on
OR, when available
# pcs node maintenance virt-002

+

# systemctl status pacemaker.service
# pcs cluster status
> Error: cluster is not currently running on this node

while it (with or without interactive prompt or an extra option set) could
connect to one the active peers (if present) and indeed show the status
for the cluster that virt-002 is still a member of (just temporarily put
into the maintenance mode).

Comment 6 Jan Pokorný [poki] 2016-03-07 15:10:15 UTC
re [comment 5]:
s/systemctl status pacemaker.service/systemctl stop pacemaker.service/

Comment 8 RHEL Program Management 2020-12-15 07:34:01 UTC
After evaluating this issue, there are no plans to address it further or fix it in an upcoming release.  Therefore, it is being closed.  If plans change such that this issue will be fixed in an upcoming release, then the bug can be reopened.


Note You need to log in before you can comment on or make changes to this bug.