Bug 1210853 - Add PIDFile option to systemd service file
Summary: Add PIDFile option to systemd service file
Keywords:
Status: CLOSED DUPLICATE of bug 1210842
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: 389-ds-base
Version: 7.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Noriko Hosoi
QA Contact: Viktor Ashirov
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-04-10 17:46 UTC by Noriko Hosoi
Modified: 2015-04-20 21:01 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-04-20 21:01:00 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Noriko Hosoi 2015-04-10 17:46:38 UTC
When stopping a dirsrv service, systemd currently guesses the PID to wait on. To make it explicit, a line like this should be added to `/usr/lib/systemd/system/dirsrv@.service`:
  PIDFile=/var/run/dirsrv/slapd-%i.pid

Comment 1 Viktor Ashirov 2015-04-20 21:01:00 UTC

*** This bug has been marked as a duplicate of bug 1210842 ***


Note You need to log in before you can comment on or make changes to this bug.