Bug 121090 - Up2date crahes with IOError message.
Up2date crahes with IOError message.
Status: CLOSED DUPLICATE of bug 117054
Product: Fedora
Classification: Fedora
Component: up2date (Show other bugs)
All Linux
medium Severity high
: ---
: ---
Assigned To: Adrian Likins
Fanny Augustin
Depends On:
Blocks: 124619
  Show dependency treegraph
Reported: 2004-04-16 19:19 EDT by Damien
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-09-05 02:25:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Damien 2004-04-16 19:19:06 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040312

Description of problem:
Up2date fails with the following error when performing any funcions,
like -l or -u.
I have tried with several mirror sites as well as the main redhat
up2date site.  Used planetmirror.com, kernel.org, and pacific.net.au.
This occurs imediately upon trying to get headers, the "Fetching rpm
headers..." line.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.Run up2date -l

Actual Results:  See crash data.

Expected Results:  Should have had a listing of packages available.

Additional info:

Here is the ouput :
Fetching Obsoletes list for channel: fedora-core-rawhide...
Fetching rpm headers...
Traceback (most recent call last):
  File "/usr/sbin/up2date-nox", line 1271, in ?
    sys.exit(main() or 0)
  File "/usr/sbin/up2date-nox", line 799, in main
    fullUpdate, dryRun=options.dry_run))
  File "/usr/sbin/up2date-nox", line 1147, in batchRun
  File "up2dateBatch.py", line 62, in run
  File "up2dateBatch.py", line 108, in __findPackagesToUpdate
  File "packageList.py", line 580, in getPackagesToInstall
  File "packageList.py", line 609, in __skipPackages
  File "packageList.py", line 630, in __skipFiles
  File "packageList.py", line 669, in buildHeaderList
  File "headers.py", line 37, in __getitem__
  File "headers.py", line 42, in __retrievePackage
  File "rpcServer.py", line 112, in doCall
  File "repoDirector.py", line 31, in getHeader
  File "rpmSource.py", line 210, in getHeader
  File "/usr/share/rhn/up2date_client/repoBackends/yumRepo.py", line
93, in getHeader
    hdrBuf = fh.read()
  File "/usr/lib/python2.3/gzip.py", line 217, in read
  File "/usr/lib/python2.3/gzip.py", line 260, in _read
  File "/usr/lib/python2.3/gzip.py", line 161, in _read_gzip_header
    raise IOError, 'Not a gzipped file'
IOError: Not a gzipped file
Comment 1 Rahul Sundaram 2005-09-05 02:25:41 EDT

*** This bug has been marked as a duplicate of 117054 ***

Note You need to log in before you can comment on or make changes to this bug.