Bug 121101 - Error activating XKB configuration.
Error activating XKB configuration.
Status: CLOSED DUPLICATE of bug 120858
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
athlon Linux
medium Severity low
: ---
: ---
Assigned To: Mike A. Harris
Depends On:
  Show dependency treegraph
Reported: 2004-04-17 02:02 EDT by Thomas Wolfe
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-21 14:02:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Thomas Wolfe 2004-04-17 02:02:49 EDT
Description of problem:
When I login to Gnome I get the following:
Error activating XKB configuration.
Probably internal X server problem.

X server version data:
The X.Org Foundation

If you report this situation as a bug, please include:
- The result of xprop -root | grep XKB
- The result of gconftool-2 -R /desktop/gnome/peripherals/keyboard/xkb

here are the results:
[thomas@mainserver thomas]$ xprop -root | grep XKB
_XKB_RULES_NAMES_BACKUP(STRING) = "xfree86", "pc105", "us", "", ""
_XKB_RULES_NAMES(STRING) = "xfree86", "pc105", "us", "", ""
[thomas@mainserver thomas]$ gconftool-2 -R
 layouts = [us]
 model = pc105
 overrideSettings = false
 options = []
[thomas@mainserver thomas]$

Version-Release number of selected component (if applicable):

How reproducible:
Just login to your Gnome desktop (yes, I did search before i posted ;)
Actual results:
error message

Expected results:
no error message
Comment 1 Daniel Malmgren 2004-04-17 07:25:26 EDT
Confirming. This started today when I upgraded from
0.6.6-0.2004_03_30.5 to 6.7.0-0.5.
Comment 2 Michal Jaegermann 2004-04-17 21:38:13 EDT
I have "XkbRules" line commented out in my configuration
and I am still seeing this error (with 6.7.0-0.5).  Possibly
related fragments of logs look like this:

(**) Option "XkbModel" "pc105"
(**) XKB: model: "pc105"
(**) Option "XkbLayout" "us"
(**) XKB: layout: "us"
(**) Option "XkbOptions" "ctrl:nocaps"
(**) XKB: options: "ctrl:nocaps"
(==) Keyboard: CustomKeycode disabled
Comment 3 Thilo Pfennig 2004-04-18 16:05:16 EDT
see also
Comment 4 raxet 2004-04-19 09:33:12 EDT
6.7.0-0.5 nets

xprop -root | grep XKB
_XKB_RULES_NAMES_BACKUP(STRING) = "xfree86", "pc105", "us", "", ""
_XKB_RULES_NAMES(STRING) = "xfree86", "pc105", "us", "", ""
gconftool-2 -R /desktop/gnome/peripherals/keyboard/xkb
 layouts = [us]
 model = pc105
 overrideSettings = true
 options = []
Comment 5 Mike A. Harris 2004-04-19 15:16:05 EDT

*** This bug has been marked as a duplicate of 120858 ***
Comment 6 Red Hat Bugzilla 2006-02-21 14:02:38 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.